Rooting Toon (or boxx)

Everything about rooting Toons 1 and 2.

Moderators: marcelr, TheHogNL, TerrorSource, Toonz

Re: Rooting Toon (or boxx)

Postby marcelr » Wed Apr 10, 2019 9:21 pm

Please ask again in a different thread. This has got nothing to do with rooting.
marcelr
Global Moderator
Global Moderator
 
Posts: 1074
Joined: May 2012
Location: Ehv

Re: Rooting Toon (or boxx)

Postby Flarrestein » Sat May 25, 2019 9:06 am

Hi, I just bought a Toon and started using the manual to root the thing.
After connecting the usb to serial to the right pins I only get strange symbols in Putty. Double checked everything but I can't find the problem.
Can't find other posts about this problem, so if anybody knows whats wrong...
Attachments
Putty.png
Putty.png (11.08 KiB) Viewed 798 times
Flarrestein
Starting Member
Starting Member
 
Posts: 5
Joined: May 2019

Re: Rooting Toon (or boxx)

Postby marcelr » Sat May 25, 2019 11:01 am

Probably wrong COM port settings:

115200 baud, 8 databits, 1 stop bit, no parity.
marcelr
Global Moderator
Global Moderator
 
Posts: 1074
Joined: May 2012
Location: Ehv

Re: Rooting Toon (or boxx)

Postby Flarrestein » Sat May 25, 2019 3:43 pm

marcelr wrote:Probably wrong COM port settings:

115200 baud, 8 databits, 1 stop bit, no parity.


Using 11520 baud doesn't work :D
Thanks
Flarrestein
Starting Member
Starting Member
 
Posts: 5
Joined: May 2019

Re: Rooting Toon (or boxx)

Postby marcelr » Sat May 25, 2019 4:52 pm

It should, because that's the rate the serial port is working at. Just to be sure, it's 115200, not 11520
marcelr
Global Moderator
Global Moderator
 
Posts: 1074
Joined: May 2012
Location: Ehv

Re: Rooting Toon (or boxx)

Postby Flarrestein » Sat May 25, 2019 4:53 pm

marcelr wrote:It should, because that's the rate the serial port is working at. Just to be sure, it's 115200, not 11520


That was the problem, needed the extra 0
Flarrestein
Starting Member
Starting Member
 
Posts: 5
Joined: May 2019

Re: Rooting Toon (or boxx)

Postby Micha_123 » Mon Sep 09, 2019 6:30 pm

im gonna crazy here rooting my toon..



Installing dropbear (2015.71-r0) to root...
Configuring dropbear.
Collected errors:
* pkg_run_script: package "dropbear" postinst script returned status 255.
* opkg_configure: dropbear.postinst returned 255.
/ #



what i need to do to install it ?
Micha_123
Starting Member
Starting Member
 
Posts: 3
Joined: September 2019

Re: Rooting Toon (or boxx)

Postby TheHogNL » Tue Sep 10, 2019 9:26 am

That's normal. Just run the postinst script yourself after opkg failed to do it. The auto root script also has this problem and runs the postinst afterwards:

Code: Select all
echo ">>> Installing dropbear"
opkg install dropbear_2015.71-r0_qb2.ipk
if [[ $? == 255 ]] ; then
  set -e
  sh /usr/lib/opkg/info/dropbear.postinst
fi
Member of the Toon Software Collective
User avatar
TheHogNL
Forum Moderator
Forum Moderator
 
Posts: 1078
Joined: August 2017

Re: Rooting Toon (or boxx)

Postby knug2 » Sat Sep 14, 2019 11:41 am

Hi,

I'm new to this forum, and trying to root my Toon with an RPI4 ( using the automated script of martenjacobs ). Currently i'm getting stuck since I have a newer toon ( bootloader R10 ).

First of all the regular startup Toonrooter command is not working :
Code: Select all
pi@raspberrypi:~/ToonRooter $ sudo python . --jtag-available
INFO:__main__:Starting up...
CRITICAL:__main__:Cannot autodetect jtag hardware


However using :

Code: Select all
pi@raspberrypi:~/ToonRooter $ sudo python . --jtag-hardware TYPE
INFO:__main__:Starting up...
INFO:__main__:Written private and public key pair to ./id_rsa and ./id_rsa.pub, respectively
INFO:rooter:Waiting for Toon to restart
INFO:rooter:Toon has U-Boot version 2010.09-R10
ERROR:rooter:Unable to log in using password (need JTAG, but it's disabled)
pi@raspberrypi:~/ToonRooter $


is working sort of?

So i've run the OPENOCD command stated at the git from martenjacobs with following output:
Code: Select all
pi@raspberrypi:~/ToonRooter $ sudo git clone --recursive git://git.code.sf.net/p/openocd/code openocd
Cloning into 'openocd'...
remote: Enumerating objects: 61666, done.
remote: Counting objects: 100% (61666/61666), done.
remote: Compressing objects: 100% (25612/25612), done.
remote: Total 61666 (delta 50663), reused 43569 (delta 35892)
Receiving objects: 100% (61666/61666), 13.99 MiB | 818.00 KiB/s, done.
Resolving deltas: 100% (50663/50663), done.
Submodule 'jimtcl' (http://repo.or.cz/r/jimtcl.git) registered for path 'jimtcl'
Submodule 'src/jtag/drivers/libjaylink' (http://repo.or.cz/r/libjaylink.git) registered for path 'src/jtag/drivers/libjaylink'
Submodule 'tools/git2cl' (http://repo.or.cz/r/git2cl.git) registered for path 'tools/git2cl'
Cloning into '/home/pi/ToonRooter/openocd/jimtcl'...
warning: redirecting to https://repo.or.cz/r/jimtcl.git/
remote: Counting objects: 7564, done.
remote: Total 7564 (delta 0), reused 0 (delta 0)        /s   s
Receiving objects: 100% (7564/7564), 5.99 MiB | 1.95 MiB/s, done.
Resolving deltas: 100% (5503/5503), done.
Cloning into '/home/pi/ToonRooter/openocd/tools/git2cl'...
warning: redirecting to https://repo.or.cz/r/git2cl.git/
remote: Counting objects: 64, done.
remote: Total 64 (delta 0), reused 0 (delta 0)
Cloning into '/home/pi/ToonRooter/openocd/src/jtag/drivers/libjaylink'...
warning: redirecting to https://repo.or.cz/r/libjaylink.git/
remote: Counting objects: 991, done.
remote: Total 991 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (991/991), 234.83 KiB | 412.00 KiB/s, done.
Resolving deltas: 100% (758/758), done.
Submodule path 'jimtcl': checked out 'a9bf5975fd0f89974d689a2d9ebd0873c8d64787'
Submodule path 'src/jtag/drivers/libjaylink': checked out '4959f4e18a2bb0de21abe66bbfe403b56f599856'
Submodule path 'tools/git2cl': checked out '8373c9f74993e218a08819cbcdbab3f3564bbeba'
pi@raspberrypi:~/ToonRooter $ cd openocd
pi@raspberrypi:~/ToonRooter/openocd $ sudo apt install make libtool libtool-bin pkg-config autoconf automake texinfo libusb-1.0 libusb-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libusb-1.0-0' for regex 'libusb-1.0'
Note, selecting 'libusb-1.0-0-dev' for regex 'libusb-1.0'
Note, selecting 'libusb-1.0-doc' for regex 'libusb-1.0'
libusb-1.0-0 is already the newest version (2:1.0.22-2).
libusb-1.0-0 set to manually installed.
make is already the newest version (4.2.1-1.2).
make set to manually installed.
pkg-config is already the newest version (0.29-6).
The following additional packages will be installed:
  autotools-dev libauthen-sasl-perl libdata-dump-perl libencode-locale-perl
  libfile-listing-perl libfont-afm-perl libhtml-form-perl libhtml-format-perl
  libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
  libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libio-html-perl
  libio-socket-ssl-perl libltdl-dev libltdl7 liblwp-mediatypes-perl
  liblwp-protocol-https-perl libmailtools-perl libnet-http-perl
  libnet-smtp-ssl-perl libnet-ssleay-perl libsigsegv2 libtext-unidecode-perl
  libtimedate-perl libtry-tiny-perl liburi-perl libusb-0.1-4 libwww-perl
  libwww-robotrules-perl libxml-libxml-perl libxml-namespacesupport-perl
  libxml-parser-perl libxml-sax-base-perl libxml-sax-expat-perl
  libxml-sax-perl m4 perl-openssl-defaults tex-common
Suggested packages:
  autoconf-archive gnu-standards autoconf-doc gettext libdigest-hmac-perl
  libgssapi-perl libtool-doc libcrypt-ssleay-perl gfortran
  | fortran95-compiler gcj-jdk libauthen-ntlm-perl libxml-sax-expatxs-perl
  m4-doc debhelper texlive-base texlive-latex-base texlive-generic-recommended
  texinfo-doc-nonfree texlive-fonts-recommended
The following NEW packages will be installed:
  autoconf automake autotools-dev libauthen-sasl-perl libdata-dump-perl
  libencode-locale-perl libfile-listing-perl libfont-afm-perl
  libhtml-form-perl libhtml-format-perl libhtml-parser-perl
  libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
  libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
  libhttp-negotiate-perl libio-html-perl libio-socket-ssl-perl libltdl-dev
  libltdl7 liblwp-mediatypes-perl liblwp-protocol-https-perl libmailtools-perl
  libnet-http-perl libnet-smtp-ssl-perl libnet-ssleay-perl libsigsegv2
  libtext-unidecode-perl libtimedate-perl libtool libtool-bin libtry-tiny-perl
  liburi-perl libusb-0.1-4 libusb-1.0-0-dev libusb-1.0-doc libusb-dev
  libwww-perl libwww-robotrules-perl libxml-libxml-perl
  libxml-namespacesupport-perl libxml-parser-perl libxml-sax-base-perl
  libxml-sax-expat-perl libxml-sax-perl m4 perl-openssl-defaults tex-common
  texinfo
0 upgraded, 51 newly installed, 0 to remove and 57 not upgraded.
Need to get 7,124 kB of archives.
After this operation, 26.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Abort.


Currently i'm stuck at this point. Can anyone help me getting further? Could it be that an RPI4 is not supported for the rooting script?

Thanks!
knug2
Starting Member
Starting Member
 
Posts: 1
Joined: September 2019

Re: Rooting Toon (or boxx)

Postby TheHogNL » Sat Sep 14, 2019 2:07 pm

Script isn't tested yet on a Pi4.
But you need --jtag-available (because of R10) and then try with --jtag-hardware rpi3 (I hope the pi4 is compatible with the pi3 on the jtag pins).

Also you openocd install failed. In the end I see 'Abort'. Try it again please.
Member of the Toon Software Collective
User avatar
TheHogNL
Forum Moderator
Forum Moderator
 
Posts: 1078
Joined: August 2017

Re: Rooting Toon (or boxx)

Postby finalcut62 » Mon Sep 16, 2019 8:51 am

I'm having a hard (that is: unsuccessful) time rooting my Toon on R10. Tried multiple Pi's on the single Toon, but all give me the "error jtag scan chain interrogation failed all zeroes" on starting OpenOCD so I cannot do a soft_reset. Triple checked wiring, used both the fully automated method as well as the 'manual' method described here. Any suggestions? Anyone in the area of Haarlem able to assist?
finalcut62
Starting Member
Starting Member
 
Posts: 4
Joined: September 2019

Re: Rooting Toon (or boxx)

Postby TheHogNL » Mon Sep 16, 2019 2:06 pm

Check the wiring for the 4th time.
Member of the Toon Software Collective
User avatar
TheHogNL
Forum Moderator
Forum Moderator
 
Posts: 1078
Joined: August 2017

Re: Rooting Toon (or boxx)

Postby finalcut62 » Mon Sep 16, 2019 2:49 pm

:D I will although my wife already complained about this consuming most of the Sunday. But could it be that JTAG header on the Toon was destroyed by me? And if so, how would that present itself? Would there be some other error code? I might grab another Toon from MP to try again....
finalcut62
Starting Member
Starting Member
 
Posts: 4
Joined: September 2019

Re: Rooting Toon (or boxx)

Postby TheHogNL » Mon Sep 16, 2019 4:10 pm

finalcut62 wrote::D I will although my wife already complained about this consuming most of the Sunday. But could it be that JTAG header on the Toon was destroyed by me? And if so, how would that present itself? Would there be some other error code? I might grab another Toon from MP to try again....


Yes could be but that would require you to put a higher voltage then the 3.3v on the wrong pins. Don't know how that would present itself though. Maybe some experienced toon rooter in your neighborhood can help you indeed.
Member of the Toon Software Collective
User avatar
TheHogNL
Forum Moderator
Forum Moderator
 
Posts: 1078
Joined: August 2017

Previous

Return to Toon Rooting

Who is online

Users browsing this forum: No registered users and 1 guest