toon activation problem

If your (rooted) Toon doesn't do what it's supposed to, post here. Dutch allowed / Posten in 't Nederlands toegestaan.

Moderator: marcelr

toon activation problem

Postby patricx » Wed Apr 18, 2018 7:15 am

Hello

i have changed config_happ_scsync.xml in the folder /HCBv2/config

but every time i reboot the toon, toon overwrite that file and come back in the wizard menu.

please can someone help me ?

patrick
patricx
Starting Member
Starting Member
 
Posts: 7
Joined: April 2018

Re: toon activation problem

Postby flamingbob » Wed Apr 18, 2018 10:06 am

Hi,

but every time i reboot the toon, toon overwrite that file and come back in the wizard menu.


Simple questions first. Have you disabled the ipsec tunnel? If you still talk to the mothership it always override that exact file.
flamingbob
Starting Member
Starting Member
 
Posts: 15
Joined: November 2016

Re: toon activation problem

Postby patricx » Wed Apr 18, 2018 6:36 pm

i have change the line

ovpn:235:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1

in

#ovpn:235:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1

but the same problem
patricx
Starting Member
Starting Member
 
Posts: 7
Joined: April 2018

Re: toon activation problem

Postby TheHogNL » Thu Apr 19, 2018 7:01 am

patricx wrote:i have change the line

ovpn:235:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1

in

#ovpn:235:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1

but the same problem


That is impossible. The scsync file is only overwritten if the openvpn is running. Did you reboot after editing the line (add the # in front)?
After the reboot, change the scsync file (look in the forum for the exact changes you need to make, this is answered over and over again), reboot again, and it would be fine then.
TheHogNL
Member
Member
 
Posts: 491
Joined: August 2017

Re: toon activation problem

Postby EJanus » Thu Apr 19, 2018 11:11 am

Or (but this is perhaps to simple :wink: ) it could be that saving the file goes wrong.


So open config_happ_scsync.xml
edit the file
save
close
open config_happ_scsync.xml again
Check if your changes were in fact saved.
EJanus
Starting Member
Starting Member
 
Posts: 19
Joined: January 2018

Re: toon activation problem

Postby patricx » Thu Apr 19, 2018 11:37 am

when i check the file config_happ_scsync.xml that's i write to the toon it's ok.

when i go to the activation center it's tell that er is no conection to the activation center.

I have follow al instructions but i do not see what's wrong.

is the a other way to see if the openvpn is running ?
patricx
Starting Member
Starting Member
 
Posts: 7
Joined: April 2018

Re: toon activation problem

Postby EJanus » Thu Apr 19, 2018 3:01 pm

But what is your problem exactly?

If you want to change the VPN status, you can do that in the file /etc/inittab and put a # in front of the line ovpn:2345:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1 as stated in the root manual.

If you want to disable the wizard menu, you can try to do that in de file config_happ_scsync.xml and check if this is there: <activated>1</activated><wizardDone>1</wizardDone> (in line 11).
EJanus
Starting Member
Starting Member
 
Posts: 19
Joined: January 2018

Re: toon activation problem

Postby patricx » Thu Apr 19, 2018 3:23 pm

Ejanus,

I have do everythink follow the root manual .

i have put # for the openvpn row and i have change config_happ_scsync.xml as you write.

I have root the toon by a rapberry pi with that script without problems or errors.

and all other thinks in the manual i have do it also.

but every time i reboot te toon it overwrite the config_happ_scsync.xml file that's te problem and i can not find the solution.
patricx
Starting Member
Starting Member
 
Posts: 7
Joined: April 2018

Re: toon activation problem

Postby patricx » Thu Apr 19, 2018 6:45 pm

in /etc/inittab

i have change flas:245:respawn:/usr/bin/startflash >/dev/null 2>&1 to #flas:245:respawn:/usr/bin/startflash >/dev/null 2>&1
and reboot the toon but then it's do not start to the home screen.

remove the # and reboot again and now the toon work
patricx
Starting Member
Starting Member
 
Posts: 7
Joined: April 2018

Re: toon activation problem

Postby EJanus » Thu Apr 19, 2018 11:08 pm

So you put the # in front of: flas:245:respawn:/usr/bin/startflash >/dev/null 2>&1

That is not going to work and Toon will not boot correctly.

You should put the # in front of: ovpn:2345:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1

So it looks like:
# ovpn:2345:respawn:/usr/sbin/openvpn --config /etc/openvpn/vpn.conf --verb 0 >/dev/null 2>&1

The # tells Toon to ignore the line after the #. So Toon can not connect to the Eneco server using vpn.

Good luck!
EJanus
Starting Member
Starting Member
 
Posts: 19
Joined: January 2018


Return to Toon issues and support (Nederlands toegestaan)

Who is online

Users browsing this forum: No registered users and 1 guest

cron