Receiver does not operate.

Forum about Rfxcom home automation Domotica devices.

Moderator: b_weijenberg

Receiver does not operate.

Postby b_weijenberg » Fri Jan 15, 2010 3:37 pm

The baud rate in the receiver is probably at 38400 while the interface runs at 4800 if you see messages like below:
50FFFA2C6A04FFF0A309FF bits=80
FA2C6A04FFF0FAFFFA2C6A04FFF071FF bits=122 from SLAVE
04FF noise or an unknown data packet received bits=4
F051 Buffer flushed due to timeout
50FFFA2C6A04FFF0356ED4 bits=80
FFFA2C6A04FFF08517FFFA2C6A04FFF0 bits=127 from SLAVE

This can happen if the "Toggle Baud rate (Don't Use)" button in RFreceiver was pushed. Execute the following steps to set the baud rate back to 4800.

USB interface:
Stop any program connected to the receiver,
start RFreceiver and connect the receiver using 38400 and click the "Toggle Baud rate (Don't Use)" button. (after this never again)
Connect the receiver in 4800 and it should operate again.
Stop RFreceiver and start the application.


LAN interface:
Stop any program connected to the receiver,
Start DeviceInstaller (delivered on the RFXCOM CD)
Set the baudrate for Channel 1 to 38400, click OK at the bottom of the page and click Apply settings
Start RFreceiver and connect the receiver using 38400 and click the "Toggle Baud rate (Don't Use)" button. (after this never again)
Set the baudrate for Channel 1 back to 4800, click OK at the bottom of the page and click Apply settings
Connect the receiver in 4800 and it should operate again.
Stop RFreceiver and Device Installer and start the application.

Note:
The channel settings in the LAN controller for a receiver must be 4800 baud,No parity, 8 bits, 1 stop bit
The channel settings in the LAN controller for a transmitter must be 4800 baud,No parity, 8 bits, 2 stop bits
User avatar
b_weijenberg
Forum Moderator
Forum Moderator
 
Posts: 1727
Joined: May 2006
Location: Netherlands

Return to Rfxcom Receivers & Transmitters Forum

Who is online

Users browsing this forum: No registered users and 1 guest