xpl-rrd troubles in xpl-perl

Forum regarding Linux Software and Home Automation Domotica.

xpl-rrd troubles in xpl-perl

Postby Kroonen » Fri Apr 18, 2008 10:21 am

Hi,

I trying to install xpl-perl the debian repos of binkey.

by running manually xpl-rrd, I get this error
Undefined subroutine &main::HELP_MESSAGE called at /usr/bin/xpl-rrd line 66.

When I look on my old machine to the binary from 0.06, there are different perl modules to use. getopt::Std, nog getop::Long

Do I need a specific package of perl??
Kroonen
Member
Member
 
Posts: 302
Joined: October 2007
Location: Netherlands

xpl-rrd troubles in xpl-perl

Postby Snelvuur » Fri Apr 18, 2008 10:38 am

You should take the latest one from xpl-perl, use the wiki to create your own .deb package, then it will also show which packages you need. He did change the getopt schema's so that is true, this will allow more/better commandline handling.

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

xpl-rrd troubles in xpl-perl

Postby Kroonen » Fri Apr 18, 2008 11:12 am

Well, dd it compile from sources, same error.
Compile and Make test etc works well.
Kroonen
Member
Member
 
Posts: 302
Joined: October 2007
Location: Netherlands

xpl-rrd troubles in xpl-perl

Postby Snelvuur » Fri Apr 18, 2008 11:25 am

Hmm i see, i have the same error. I'll see if beanz is online, if not i'll create a ticket for him.

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

xpl-rrd troubles in xpl-perl

Postby Snelvuur » Fri Apr 18, 2008 11:40 am

If you know the correct syntax for the xpl-rrd it wont show the HELP message, so i think it should still work then :-)

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands


Return to Linux Forum

Who is online

Users browsing this forum: No registered users and 1 guest