Belkin Lan USB HUB

Forum about Domotica related gadget like Pocketpc, UMPC, Smartphones, Ipad Etc

Moderator: TANE

Francois
Member
Member
Posts: 255
Joined: Mon Apr 21, 2008 3:16 pm
Location: Netherlands

Belkin Lan USB HUB

Post by Francois »

Just one tip, today I joined my Homeseer server to my Small Business Server 2008 Domain and suddenly the USB hub stopped working!

Cause: a group policy that switches on the Windows XP firewall.
Solution: create an exception for both UDP as TCP on the port used by Belkin, refer to the help file for details section "firewall"

Good luck!

Francois
________________________________________________________________________________________________________________________
Digit
Global Moderator
Global Moderator
Posts: 3388
Joined: Sat Mar 25, 2006 10:23 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Digit »

The Belkin LAN USB hub doesn't work for virtual machines on MS Windows Server 2008 with Hyper-V role. The Belkin Control Center software won't install on VM's with server OS's (w2k3 x64, w2k), this was expected. The Belkin CC does install on XP Pro SP3. It does recognize the USB devices, but driver install fails and from the Device Manager it shows code 39 (corrupted or missing driver).
I tested this with 2 different USB memory sticks and a USB camera.
User avatar
TANE
Forum Moderator
Forum Moderator
Posts: 4806
Joined: Fri Apr 06, 2007 9:46 pm
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by TANE »

Robert,
I have tested with Vmware machines...all did work fine..even the Vmware machines running on my Imac
It will not install on a server...for this you have no other options than USBanywhere.
Bwired
Administrator
Administrator
Posts: 4703
Joined: Sat Mar 25, 2006 1:07 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Bwired »

Same for the Icy Box
http://www.komplett.nl/k/ki.aspx?sku=391086
Only drivers for XP or Vista. So no use for me, next time i need to be more careful!
Digit
Global Moderator
Global Moderator
Posts: 3388
Joined: Sat Mar 25, 2006 10:23 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Digit »

Same here [:)]
And USB support for Hyper-V doesn't seem to be high prio for MS, so i'll have to find another solution.
My thoughts 'this is to good to be true' as mentioned in an earlier post in this topic, become true after all. I hoped i was wrong..[:(]
Bastiaan
Senior Member
Senior Member
Posts: 1257
Joined: Sat May 24, 2008 11:36 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Bastiaan »

There will be no USB support for HyperV. But for me it worked inside the VM's when they were running WinXP. I had no driver problems there.
Bastiaan
Digit
Global Moderator
Global Moderator
Posts: 3388
Joined: Sat Mar 25, 2006 10:23 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Digit »

Strange...
Any hints, tips? I don't like having things running on the host, the Belkin was the major trigger for me to create a XP VM, expecting that to work where all other VMs failed to.[:(]
DJF3
Advanced Member
Advanced Member
Posts: 895
Joined: Thu Jul 12, 2007 9:28 am
Contact:

Belkin Lan USB HUB

Post by DJF3 »

bWired,

So you tested the Icy Box that only has XP/Vista drivers.
My VMWare server (host) is XP. After installing the drivers onto XP, do you think I would be able to use the USB ports in a Win2k virtual machine running on that XP host?

2nd question: Does the Belkin box have the same problem?

DJ
Bwired
Administrator
Administrator
Posts: 4703
Joined: Sat Mar 25, 2006 1:07 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Bwired »

Hi DJ,
I think this will work like Digits Belkin
I can send you you the box if you want, you try it out, if it works you can pay me 40 euro :-)
The thing is brand new.
Digit
Global Moderator
Global Moderator
Posts: 3388
Joined: Sat Mar 25, 2006 10:23 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Digit »

Installing drivers on the host will not help for the VM.
Regarding the Belkin: IIRC the Belkin software doesn't like Server OS's like Win2k. So your VM should be XP i guess. Also read http://www.domoticaforum.eu/topic.asp?TOPIC_ID=1890 with my latest findings regarding the Belkin.
Digit
Global Moderator
Global Moderator
Posts: 3388
Joined: Sat Mar 25, 2006 10:23 am
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Digit »

PS. I am talking about Hyper-V, not VMWare, so there may be differences since some VMWare has better USB support.
jruys
Starting Member
Starting Member
Posts: 38
Joined: Tue Dec 30, 2008 1:41 pm
Location: Netherlands

Belkin Lan USB HUB

Post by jruys »

> The Belkin Control Center software won't install on VM's with server OS's (w2k3 x64, w2k), this was expected. The Belkin CC does install on XP Pro SP3.

I've got it working on Win2K3 server, though the Belkin driver indeed doesn't work.

After looking at the .inf files I found the OEM supplier of the chipset used, and they do have a Win2K driver! Go to www.silexeurope.com and look for the drivers for the sx-1000u. The software is scarily similar!

If you prefer the Belkin control center, you can just copy the files off the CD. Once the Silex driver is installed all seems to work well.

I now have this running with my Bluetooth dongle connected remotely to Homeseer's BT plugin. Kewl :-)

/JW
DJF3
Advanced Member
Advanced Member
Posts: 895
Joined: Thu Jul 12, 2007 9:28 am
Contact:

Belkin Lan USB HUB

Post by DJF3 »

Great tip JW!

I now have my BT dongle connect to the Belkin straight from my Windows 2000 Server Virtual Machine (VMWare server)!
Works like a charm! (now we need a better range for the Asus BT dongle ;-)


Cheers
DJ
DJF3
Advanced Member
Advanced Member
Posts: 895
Joined: Thu Jul 12, 2007 9:28 am
Contact:

Belkin Lan USB HUB

Post by DJF3 »

Note that I installed the silex 3.3 (or 3.1) driver sw and copied the entire belkin sw directory from my other PC. So I'm using the Silex driver and the Belkin Connect sw. This seems to work very stable.

With the Silex connect sw I noticed that it keeps disconnecting my BT dongle every now and then.

DJ
User avatar
Snelvuur
Forum Moderator
Forum Moderator
Posts: 3156
Joined: Fri Apr 06, 2007 11:01 pm
Location: Netherlands
Contact:

Belkin Lan USB HUB

Post by Snelvuur »

btw, a new type has arrived from iogear.. http://www.iogear.com/product/GUIP204/

// Erik (binkey.nl)
Post Reply

Return to “Gadgets Forum”