Belkin Lan USB HUB

Forum about Domotica related gadget like Pocketpc, UMPC, Smartphones, Ipad Etc

Moderator: TANE

Belkin Lan USB HUB

Postby Francois » Fri Nov 14, 2008 5:42 pm

Just one tip, today I joined my Homeseer server to my Small Business Server 2008 Domain and suddenly the USB hub stopped working!

Cause: a group policy that switches on the Windows XP firewall.
Solution: create an exception for both UDP as TCP on the port used by Belkin, refer to the help file for details section "firewall"

Good luck!

Francois
________________________________________________________________________________________________________________________
Francois
Member
Member
 
Posts: 255
Joined: April 2008
Location: Netherlands

Belkin Lan USB HUB

Postby Digit » Fri Nov 21, 2008 11:51 pm

The Belkin LAN USB hub doesn't work for virtual machines on MS Windows Server 2008 with Hyper-V role. The Belkin Control Center software won't install on VM's with server OS's (w2k3 x64, w2k), this was expected. The Belkin CC does install on XP Pro SP3. It does recognize the USB devices, but driver install fails and from the Device Manager it shows code 39 (corrupted or missing driver).
I tested this with 2 different USB memory sticks and a USB camera.
User avatar
Digit
Global Moderator
Global Moderator
 
Posts: 3388
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby TANE » Fri Nov 21, 2008 11:56 pm

Robert,
I have tested with Vmware machines...all did work fine..even the Vmware machines running on my Imac
It will not install on a server...for this you have no other options than USBanywhere.
User avatar
TANE
Forum Moderator
Forum Moderator
 
Posts: 4806
Joined: April 2007
Location: Netherlands

Belkin Lan USB HUB

Postby Bwired » Fri Nov 21, 2008 11:57 pm

Same for the Icy Box
http://www.komplett.nl/k/ki.aspx?sku=391086
Only drivers for XP or Vista. So no use for me, next time i need to be more careful!
User avatar
Bwired
Administrator
Administrator
 
Posts: 5305
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby Digit » Sat Nov 22, 2008 12:12 am

Same here [:)]
And USB support for Hyper-V doesn't seem to be high prio for MS, so i'll have to find another solution.
My thoughts 'this is to good to be true' as mentioned in an earlier post in this topic, become true after all. I hoped i was wrong..[:(]
User avatar
Digit
Global Moderator
Global Moderator
 
Posts: 3388
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby Bastiaan » Sat Nov 22, 2008 12:36 am

There will be no USB support for HyperV. But for me it worked inside the VM's when they were running WinXP. I had no driver problems there.
Bastiaan
Bastiaan
Senior Member
Senior Member
 
Posts: 1245
Joined: May 2008
Location: Netherlands

Belkin Lan USB HUB

Postby Digit » Sat Nov 22, 2008 1:23 am

Strange...
Any hints, tips? I don't like having things running on the host, the Belkin was the major trigger for me to create a XP VM, expecting that to work where all other VMs failed to.[:(]
User avatar
Digit
Global Moderator
Global Moderator
 
Posts: 3388
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby DJF3 » Thu Dec 25, 2008 11:58 am

bWired,

So you tested the Icy Box that only has XP/Vista drivers.
My VMWare server (host) is XP. After installing the drivers onto XP, do you think I would be able to use the USB ports in a Win2k virtual machine running on that XP host?

2nd question: Does the Belkin box have the same problem?

DJ
User avatar
DJF3
Advanced Member
Advanced Member
 
Posts: 886
Joined: July 2007

Belkin Lan USB HUB

Postby Bwired » Thu Dec 25, 2008 12:27 pm

Hi DJ,
I think this will work like Digits Belkin
I can send you you the box if you want, you try it out, if it works you can pay me 40 euro :-)
The thing is brand new.
User avatar
Bwired
Administrator
Administrator
 
Posts: 5305
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby Digit » Thu Dec 25, 2008 1:32 pm

Installing drivers on the host will not help for the VM.
Regarding the Belkin: IIRC the Belkin software doesn't like Server OS's like Win2k. So your VM should be XP i guess. Also read topic.asp?TOPIC_ID=1890 with my latest findings regarding the Belkin.
User avatar
Digit
Global Moderator
Global Moderator
 
Posts: 3388
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby Digit » Thu Dec 25, 2008 1:34 pm

PS. I am talking about Hyper-V, not VMWare, so there may be differences since some VMWare has better USB support.
User avatar
Digit
Global Moderator
Global Moderator
 
Posts: 3388
Joined: March 2006
Location: Netherlands

Belkin Lan USB HUB

Postby jruys » Wed Jan 14, 2009 9:49 am

> The Belkin Control Center software won't install on VM's with server OS's (w2k3 x64, w2k), this was expected. The Belkin CC does install on XP Pro SP3.

I've got it working on Win2K3 server, though the Belkin driver indeed doesn't work.

After looking at the .inf files I found the OEM supplier of the chipset used, and they do have a Win2K driver! Go to www.silexeurope.com and look for the drivers for the sx-1000u. The software is scarily similar!

If you prefer the Belkin control center, you can just copy the files off the CD. Once the Silex driver is installed all seems to work well.

I now have this running with my Bluetooth dongle connected remotely to Homeseer's BT plugin. Kewl :-)

/JW
jruys
Starting Member
Starting Member
 
Posts: 38
Joined: December 2008
Location: Netherlands

Belkin Lan USB HUB

Postby DJF3 » Wed Jan 14, 2009 10:21 am

Great tip JW!

I now have my BT dongle connect to the Belkin straight from my Windows 2000 Server Virtual Machine (VMWare server)!
Works like a charm! (now we need a better range for the Asus BT dongle ;-)


Cheers
DJ
User avatar
DJF3
Advanced Member
Advanced Member
 
Posts: 886
Joined: July 2007

Belkin Lan USB HUB

Postby DJF3 » Wed Jan 14, 2009 8:14 pm

Note that I installed the silex 3.3 (or 3.1) driver sw and copied the entire belkin sw directory from my other PC. So I'm using the Silex driver and the Belkin Connect sw. This seems to work very stable.

With the Silex connect sw I noticed that it keeps disconnecting my BT dongle every now and then.

DJ
User avatar
DJF3
Advanced Member
Advanced Member
 
Posts: 886
Joined: July 2007

Belkin Lan USB HUB

Postby Snelvuur » Wed Mar 25, 2009 11:41 am

btw, a new type has arrived from iogear.. http://www.iogear.com/product/GUIP204/

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

PreviousNext

Return to Gadgets Forum

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest