Greenwave powernode 6

Forum about Domotiga Open Source Home Automation for Linux.

Moderator: RDNZL

Greenwave powernode 6

Postby vanisher » Sun Feb 24, 2013 10:32 pm

I'm currently investigating Domotiga (finally :) )

BUT i have some issues with the powernode 6. If I add that device to domotiga I only see one device instead of 7 (at least 7 in homeseer).

What am i doing wrong?
-------------------------------------------------------------------
A Domotica starter, currently running: Plugwise, Z-Wave, Jeenods, Homeseer / DomotiGa
vanisher
Member
Member
 
Posts: 293
Joined: June 2011

Re: Greenwave powernode 6

Postby wwolkers » Mon Feb 25, 2013 12:48 pm

What version DomotiGa / OpenZwave are you using?
I am running the Powernode 6 without any problems.
wwolkers
Member
Member
 
Posts: 273
Joined: September 2008
Location: Netherlands

Re: Greenwave powernode 6

Postby vanisher » Mon Feb 25, 2013 1:17 pm

DomotiGa 1.0.003
OpenZwave Revision: 643
-------------------------------------------------------------------
A Domotica starter, currently running: Plugwise, Z-Wave, Jeenods, Homeseer / DomotiGa
vanisher
Member
Member
 
Posts: 293
Joined: June 2011

Re: Greenwave powernode 6

Postby wwolkers » Mon Feb 25, 2013 2:16 pm

in your wrappers/domozwave directory there should be a file zwcfg*.xml

In that file you should find a node with Manufacturer name GreenWave, here's (part of) mine for example:

<Node id="2" name="" location="" basic="4" generic="16" specific="1" typ
e="Binary Power Switch" listening="true" frequentListening="false" beaming="true
" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">
<Manufacturer id="0099" name="GreenWave">
<Product type="0003" id="0004" name="PowerNode 6 port" />
</Manufacturer>
<CommandClasses>
<CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="5" mapping="37">
<Instance index="1" endpoint="1" />
<Instance index="2" endpoint="2" />
<Instance index="3" endpoint="3" />
<Instance index="4" endpoint="4" />
<Instance index="5" endpoint="5" />
<Instance index="6" endpoint="6" />

As you can see, mine detects 6 instances for that node.

Can you attach your zwcfg*.xml file, or check how your GreenWave node gets detected?

If you tried running with an older version of openz-wave,you can try deleting the file, in which case a discovery of the entire Z-Wave network is done again.
wwolkers
Member
Member
 
Posts: 273
Joined: September 2008
Location: Netherlands

Re: Greenwave powernode 6

Postby vanisher » Mon Feb 25, 2013 8:08 pm

I don't have a zwcfg*.xml file in the domozwave directory.
If i look at the Zwave manager i see all the Z-wave devices including the Powernode 6 (greenwave) on ID 44

Little site-step, i took the aeonlabs stick from a working Homeseer environment. So everything is connected already to the stick.

I haven't created a device yet.


--Edit

I was too quick.

After about 30 minutes i saw a log entry (zwave interface is fully initialized)
And here we are, an XML file:

Code: Select all
        <Node id="44" name="" location="" basic="4" generic="16" specific="1" type="Binary Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">
                <Manufacturer id="0099" name="GreenWave">
                        <Product type="0003" id="0004" name="PowerNode 6 port" />
                </Manufacturer>
                <CommandClasses>
                        <CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="5" mapping="37">
                                <Instance index="1" endpoint="1" />
                                <Instance index="2" endpoint="2" />
                                <Instance index="3" endpoint="3" />
                                <Instance index="4" endpoint="4" />
                                <Instance index="5" endpoint="5" />
                                <Instance index="6" endpoint="6" />
                        </CommandClass>


AND all ports are available!!

Wowie, up to the next journey, Jeenodes :D
-------------------------------------------------------------------
A Domotica starter, currently running: Plugwise, Z-Wave, Jeenods, Homeseer / DomotiGa
vanisher
Member
Member
 
Posts: 293
Joined: June 2011

Re: Greenwave powernode 6

Postby wwolkers » Mon Feb 25, 2013 8:23 pm

Good to see it's working!
Jeenodes are supported in DomotiGa, but not everything yet.
Currently only the default roomnode format is supported.
wwolkers
Member
Member
 
Posts: 273
Joined: September 2008
Location: Netherlands

Re: Greenwave powernode 6

Postby vanisher » Mon Feb 25, 2013 8:42 pm

Is that with a special sketch or something? Or just the default jeelink / jeenode sketch?
-------------------------------------------------------------------
A Domotica starter, currently running: Plugwise, Z-Wave, Jeenods, Homeseer / DomotiGa
vanisher
Member
Member
 
Posts: 293
Joined: June 2011

Re: Greenwave powernode 6

Postby wwolkers » Mon Feb 25, 2013 9:20 pm

Defaul RoomNode sketch is supported.
wwolkers
Member
Member
 
Posts: 273
Joined: September 2008
Location: Netherlands

Re: Greenwave powernode 6

Postby uAlex73 » Tue Feb 26, 2013 9:44 am

@vanisher:

If it takes 30 minutes before the the open-zwave is fully initialized, can you check which revision you're running? With r640+ this should be fast - within a few minutes max (or else some devices not always respond properly)

ps. the zwcfg*xml will only be created/updated AFTER it is fully initialized. This is a behavior of open-zwave, not of DomotiGa.
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Re: Greenwave powernode 6

Postby vanisher » Tue Feb 26, 2013 10:09 am

Alex,

DomotiGa 1.0.003
OpenZwave Revision: 643

Currently everything is discovered, but the powernodes are not updating the watt / KWh stats.
-------------------------------------------------------------------
A Domotica starter, currently running: Plugwise, Z-Wave, Jeenods, Homeseer / DomotiGa
vanisher
Member
Member
 
Posts: 293
Joined: June 2011

Re: Greenwave powernode 6

Postby uAlex73 » Tue Feb 26, 2013 2:43 pm

You need to poll for the values, because they aren't automatically updated. Check the Z-Wave settings and enable "Poll listening" devices, an internal of 10 minutes (*/10 * * * *) is a good start.
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Re: Greenwave powernode 6

Postby uAlex73 » Tue Feb 26, 2013 2:46 pm

ps. can you also attach the zwcfg*xml & OZW_Log.txt after it fully initialized, because it should take <2 minutes to complete. Then i will have a look if it is 1 specific device, because your open-zwave is up-to-date.
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Re: Greenwave powernode 6

Postby vanisher » Tue Feb 26, 2013 6:52 pm

Yes!

Z-Wave is working, polling is working i get new values.. so that (for me) mystery is fixed.

Another mystery started:

I enabled rrdtool
I enabled graphs on a device. the logfile says that the <id>.rrd is created.. but nothing in the rrd directory.

Edit: Hmz, you have to fill in a type for every value.

Which type do you need to graph an on / off status?
-------------------------------------------------------------------
A Domotica starter, currently running: Plugwise, Z-Wave, Jeenods, Homeseer / DomotiGa
vanisher
Member
Member
 
Posts: 293
Joined: June 2011

Re: Greenwave powernode 6

Postby christiand » Thu Feb 28, 2013 9:22 pm

I am also new to domotiga, but did got the powernode 6 added. I have added the overall on/off switch and meter as a device now, but how do you add every single switch? Do you add the value of the instance at the "Node ID". So node 7 instance 2 is 7:2?

Umbuntu: 12.04 x86
Domotiga: 1.0.003 (Gambas3 version)
OpenZwave: 643

I found the logfiles and somehow it says it can't find the specific instances.

2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 2 value1 changed to Off.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:2' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 3 value1 changed to On.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:3' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 4 value1 changed to On.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:4' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 5 value1 changed to On.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:5' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 6 value1 changed to Off.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:6' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 1 value3 changed to 0.0838.
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 1 value2 changed to 0.8.
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 2 value3 changed to 0.3479.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:2' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 2 value2 changed to 0.0.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:2' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 3 value3 changed to 2.8328.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:3' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 3 value2 changed to 0.2.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:3' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 4 value3 changed to 2.5442.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:4' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 4 value2 changed to 18.4.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:4' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 5 value3 changed to 0.0279.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:5' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 5 value2 changed to 0.2.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:5' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 6 value3 changed to 0.2022.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:6' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:42 [Z-Wave] Got value changed notification for node 7 and instance 6 value2 changed to 0.0.
2013/02/28 22:39:42 [Devices] Device of type 'ZWAVE' with address '7:6' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 1 value1 changed to On.
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 2 value1 changed to Off.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:2' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 3 value1 changed to On.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:3' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 4 value1 changed to On.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:4' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 5 value1 changed to On.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:5' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 6 value1 changed to On.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:6' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 1 value3 changed to 0.1072.
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 1 value2 changed to 7.4.
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 2 value3 changed to 0.0749.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:2' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 2 value2 changed to 0.0.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:2' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 3 value3 changed to 0.0000.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:3' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 3 value2 changed to 0.0.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:3' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 4 value3 changed to 0.0000.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:4' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 4 value2 changed to 0.0.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:4' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:43 [Z-Wave] Got value changed notification for node 8 and instance 5 value3 changed to 0.0000.
2013/02/28 22:39:43 [Devices] Device of type 'ZWAVE' with address '8:5' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:44 [Z-Wave] Got value changed notification for node 8 and instance 5 value2 changed to 0.0.
2013/02/28 22:39:44 [Devices] Device of type 'ZWAVE' with address '8:5' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:44 [Z-Wave] Got value changed notification for node 8 and instance 6 value3 changed to 0.0000.
2013/02/28 22:39:44 [Devices] Device of type 'ZWAVE' with address '8:6' and interface 'Z-Wave Controller' not found!
2013/02/28 22:39:44 [Z-Wave] Got value changed notification for node 8 and instance 6 value2 changed to 0.0.
2013/02/28 22:39:44 [Devices] Device of type 'ZWAVE' with address '8:6' and interface 'Z-Wave Controller' not found!
christiand
Member
Member
 
Posts: 69
Joined: October 2010

Re: Greenwave powernode 6

Postby uAlex73 » Fri Mar 01, 2013 8:01 am

Yes, for a PowerNode 6 you need to add 6 devices (addresses are):
7 - first socket
7:2 - second socket
7:3 - third socket
7:4 - fourth socket
7:5 - fifth socket
7:6 - sixth socket

The On/Off, Watt and kWh will be saved within 1 device for that specific socket information.
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Next

Return to DomotiGa Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron