No devices in web interface

Forum about Domotiga Open Source Home Automation for Linux.

Moderator: RDNZL

No devices in web interface

Postby mschut » Thu Sep 19, 2013 11:12 pm

On to the next issue....

I am not sure what caused it, but in the web interface of DomotiGa (on Raspberry Pi) I don't see any devices anymore. I did use to see them, but they are gone.

I did upgrade to the latest version, and changed from gambas2 to gambas 3, although due to some problems acheiving this, I am not sure the upgrade by itself / the gambas upgrade could be the problem. However, trying to reinstall according to the manual on http://www.domotiga.nl didn't bring the devices back.

Anyone recognise this as a "simple" issue (and hopefully with a simply solution)?
Synology DS213+ / Domoticz / RFX Transceiver-e
mschut
Starting Member
Starting Member
 
Posts: 32
Joined: March 2012
Location: the Netrherlands

Re: No devices in web interface

Postby uAlex73 » Sat Sep 21, 2013 4:15 pm

Can you try the following command:
Code: Select all
$ xmlrpc 127.0.0.1:9009 device.list

It is should respond with something like:
Code: Select all
Result:

Struct of 25 members:
  Key:   String: 'Porch Light'
  Value: String: '1;;light-on.png;;Porch Light;;Frontdoor;;On;;;;;;;;;;;;;;;;2008-12-14 18:00:00;;;;T;;'
  Key:   String: 'Power Usage'
  Value: String: '2;;energy.png;;Power Usage;;MeterCabinet;;4497256;;;;0;;Watt;;;;;;;;;;2008-12-14 21:53:01;;;;;;'
...
...
...
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Re: No devices in web interface

Postby mschut » Tue Nov 26, 2013 10:30 pm

Note: I've been away from this forum awhile because my uptime of my raspberry was very poor.. I changed the device, and hopefully now it will stay on again.

Anyway, I've tried the suggestion, it says:

Code: Select all
-bash: xmlrpc: command not found


That's not very helpful is it...
Synology DS213+ / Domoticz / RFX Transceiver-e
mschut
Starting Member
Starting Member
 
Posts: 32
Joined: March 2012
Location: the Netrherlands

Re: No devices in web interface

Postby RDNZL » Sat Nov 30, 2013 5:06 pm

You have to install it first.
On my Ubuntu distro it's in libxmlrpc-core-c3-dev
$ sudo apt-get install libxmlrpc-core-c3-dev
Regards, Ron.
User avatar
RDNZL
Forum Moderator
Forum Moderator
 
Posts: 996
Joined: September 2006
Location: Dordrecht, The Netherlands

Re: No devices in web interface

Postby mschut » Sun Dec 01, 2013 10:52 pm

I have reinstalled everything on the page Web & Mobile Clients - Domotiga but stil... NO devices at all. The webpage http://www.mydomain.com/domotiga is working, the iphone client http://www.mydomain.com/iphone is working. The only issue missing are the devices.

Oh please, it took me another evening without any result. Has anybody an idea? Since I followed everything on the page mentioned, I have the feeling the required xmlrpc should be there. It did mention some xmlrpx with the php5 files, but as I said, no change to the good has been achieved....

Situation:
Raspberry PI B
DomotiGa 1.0.009.
Synology DS213+ / Domoticz / RFX Transceiver-e
mschut
Starting Member
Starting Member
 
Posts: 32
Joined: March 2012
Location: the Netrherlands

Re: No devices in web interface

Postby uAlex73 » Mon Dec 02, 2013 7:01 am

@mschut:

There can also be something "weird" in the xml response, can you make a tcpdump of the xml-rpc traffic and email it to me?

to make a tcpdump:

sudo tcpdump -i any -s 0 -w /var/tmp/xml.eth port 9009
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Re: No devices in web interface

Postby mschut » Mon Dec 02, 2013 7:11 am

Thanks for the reply, I quickly tried, but again:

Sudo: tcpdump: command not found

Something is missing I suppose.....
Synology DS213+ / Domoticz / RFX Transceiver-e
mschut
Starting Member
Starting Member
 
Posts: 32
Joined: March 2012
Location: the Netrherlands

Re: No devices in web interface

Postby uAlex73 » Tue Dec 03, 2013 11:19 am

You can install tcpdump as follows:
$ sudo apt-get install tcpdump
DomotiGa / Z-Wave / RFXCom / Visonic PowerMaster / Home Assistant / Zigbee2MQTT / DSMR Reader / Toon1 (rooted)
uAlex73
Member
Member
 
Posts: 217
Joined: January 2012

Re: No devices in web interface

Postby mschut » Tue Dec 03, 2013 9:06 pm

Installed, check.
Performed command, check.
Mailed the file, check.

For me, It doesn't make any sense what's in the file :shock:
Synology DS213+ / Domoticz / RFX Transceiver-e
mschut
Starting Member
Starting Member
 
Posts: 32
Joined: March 2012
Location: the Netrherlands

Re: No devices in web interface

Postby mschut » Wed Dec 04, 2013 8:32 am

Found the error, thanks to uAlex73!

"Do not use an "&" in the names of the devices/locations".

Now I know...
Synology DS213+ / Domoticz / RFX Transceiver-e
mschut
Starting Member
Starting Member
 
Posts: 32
Joined: March 2012
Location: the Netrherlands


Return to DomotiGa Forum

Who is online

Users browsing this forum: No registered users and 1 guest