Plugwise-2-py - an evolution of earlier python/linux work

Plugwise Forum about Plugwise devices and the Source software.

Re: Plugwise-2-py - an evolution of earlier python/linux work

Postby Edwin » Sat Mar 04, 2017 3:40 pm

almost everything is working now :)
only the sheduler is a problem, its not working.
i made a shedule for saterday to go on at 08:00 and off at 21:00 the squares are orange in the on settings and grey in the off settings.
I did set the switch "shedule on " to on in the webapp but the plugwise plug stays on all the time.
what am i doing wrong here?




thanks
edwin
Edwin
Member
Member
 
Posts: 446
Joined: October 2007
Location: Netherlands

Re: Plugwise-2-py - an evolution of earlier python/linux work

Postby SevenW » Thu Mar 09, 2017 12:45 am

Hi Edwin,

I thought everything with schedules was finally OK for the last few months. Apparently not. Can you send me an email for user info at the domain of my website? See github to figure it out. I need to take a look at your log files and config files.

SevenW
SevenW
Starting Member
Starting Member
 
Posts: 26
Joined: May 2012

Re: Plugwise-2-py - an evolution of earlier python/linux work

Postby mvdp » Tue Jul 25, 2017 8:19 am

Hi Steven,
Thanks for the great work on plugwise-2-py. I've got it running in my house with 12 circles and Domoticz which runs fantastico.
There is a strange thing with plugwise-2-web.py service and websockets. On some devices (macbook air, linux box, ipad 2) and Chrome the measurements are showing and updating. However, on newer devices (ipad mini, iphone 6) with chrome and on the macbook air with safari the measurements are not showing.

Before I start an extensive debug session I would like to know if this sounds familiar to you and if you have a clue?

Thanks,
Martin\

Edit. I started to check the developers tool in Safari. When connecting with Plugwise-2-web.py it logs multiple messages like:

WebSocket connection to 'ws://diskstation:8000/socket.ws' failed: Invalid HTTP version string: HTTP/1.0

Googling a bit further shows this link.
I'll try if I can fix this in my git checkout.
mvdp
Starting Member
Starting Member
 
Posts: 4
Joined: January 2017

Re: Plugwise-2-py - an evolution of earlier python/linux work

Postby mvdp » Wed Jul 26, 2017 7:34 am

I found out that setting the protocol version in swutil/HTTPWebSocketsHandler.py did the trick.
After the line with
_opcode_pong = 0xa
add
protocol_version = 'HTTP/1.1'

and restart Plugwise-2-web.py
mvdp
Starting Member
Starting Member
 
Posts: 4
Joined: January 2017

Re: Plugwise-2-py - an evolution of earlier python/linux work

Postby Bwired » Wed Jul 26, 2017 7:55 pm

top :)
User avatar
Bwired
Administrator
Administrator
 
Posts: 5299
Joined: March 2006
Location: Netherlands

Previous

Return to Plugwise Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron