Smile /smartmeter/modules starts redirecting to index.html

Plugwise Forum about Plugwise devices and the Source software.

Smile /smartmeter/modules starts redirecting to index.html

Postby brammh » Sun Mar 29, 2015 10:32 pm

Hi,
I've some scripting running for ages, which suddenly stopped.
Looks like the Smile log's cannot be found anymore on:
'myip/smartmeter/modules'
in fact this URI now redirects me to 'myip/html_interface/index.html'

I've no clue what triggered this, didn't trigger a firmware upload or such.
running on version 2.0.62

anyone any clue?

thanks a lot.
bram
brammh
Starting Member
Starting Member
 
Posts: 7
Joined: August 2012

Re: Smile /smartmeter/modules starts redirecting to index.html

Postby PietjeNL » Thu Apr 02, 2015 9:10 am

Whats the normal output u get from it?
PietjeNL
Member
Member
 
Posts: 148
Joined: May 2010

Re: Smile /smartmeter/modules starts redirecting to index.html

Postby brammh » Thu Apr 02, 2015 10:02 pm

an xml with values for the registered devices to the smile. like:

<?xml version="1.0" encoding="ISO-8859-1"?>
<modules>
<module id='123...'>
<cumulative_logs>
<cumulative_log>
<type>gas_consumed</type>
<unit>m3</unit>
<last_consecutive_log_date>2013-01-03T21:00:00+00:00</last_consecutive_log_date>
<period start_date="2012-12-07T17:00:00+00:00" end_date="2013-01-03T21:00:00+00:00">
<measurement log_date="2013-01-03T20:00:00+00:00">78.021</measurement>
...

Anyone else has this problem? I don't understand where it is suddenly coming from.
thanks,
bram
brammh
Starting Member
Starting Member
 
Posts: 7
Joined: August 2012

Re: Smile /smartmeter/modules starts redirecting to index.html

Postby bonza » Mon Apr 06, 2015 6:34 am

I am having the same problem, it also started around that date. My fimeware is 2.0.62
My smile was also linked to the source, but the source sees no new values after 29 march....

Very annoying feels like a hidden background sw update from plugwise....
Jeroen...
bonza
Starting Member
Starting Member
 
Posts: 7
Joined: September 2008
Location: Netherlands

Re: Smile /smartmeter/modules starts redirecting to index.html

Postby bonza » Mon Apr 06, 2015 6:57 am

http://smile-ip/core/modules still gives some useable xml output.
Jeroen...
bonza
Starting Member
Starting Member
 
Posts: 7
Joined: September 2008
Location: Netherlands

Re: Smile /smartmeter/modules starts redirecting to index.html

Postby brammh » Wed Apr 08, 2015 10:13 pm

Brilliant!
Thanks a lot Jeroen, this solves my issue.

Still strange this happened suddenly...
brammh
Starting Member
Starting Member
 
Posts: 7
Joined: August 2012


Return to Plugwise Forum

Who is online

Users browsing this forum: No registered users and 4 guests

cron