Qubino self-made temperature sensor

Forum and Topics about Z-Wave devices.

Qubino self-made temperature sensor

Postby stefxx » Sat Oct 29, 2016 9:09 pm

Hi!

I am using a lot of Qubino Z-Wave Plus modules, mainly Flush 2 Relays and Dimmers, but also Flush 1 and Shutter modules. All of those modules have a temperature connector, however 15 euro's for a few components that are below 1 USD seems not ok. And making stuff yourself is always more fun!

This is what I could find on the topic:
- https://community.zipato.com/topic/has- ... ino-relays
- https://www.domoticz.com/forum/viewtopi ... 507#p66613

I know they are talking about the non-Plus version of the Qubino's, but as I don't find any temperature sensors specific for the Plus version, I assume they are the same.

So, I ordered the following items:
- DS18B20 TO-92 Temperature Sensor Dallas Thermometer Temperature Sensor: http://www.ebay.com/itm/371587586628
- JST ZH 1.5mm 3-Pin Female Connector Plug with Wire and Male Connector: http://www.ebay.com/itm/262498689224

Note that most sites claim the connector is a 1.25mm 3-Pin JST, but that will not fit. You need a 1.5mm 3-Pin JST-ZH connector.

So, I soldered two sets and started testing... but as soon as I connect them, the module blocks and become non-responsive. Local and remote switching is no longer possible, including or excluding the module doesn't work either. Removing the sensor fixes this immediately.

I have triple-checked the sensors, and I am absolutely sure I connected them according to the links above. What could be wrong?

Thanks!
User avatar
stefxx
Advanced Member
Advanced Member
 
Posts: 647
Joined: September 2008
Location: Netherlands

Re: Qubino self-made temperature sensor

Postby stefxx » Sat Mar 25, 2017 8:41 pm

Ok, to answer an old post of myself; I found out that not all DS18B20 are the same. I hade two batches, both didn't work. I recently got another batch, and they all do work...

So, for anyone interested:

Does NOT work:
no1.jpg
no1.jpg (121.89 KiB) Viewed 1604 times


Does NOT work:
no2.jpg
no2.jpg (104.3 KiB) Viewed 1604 times


Does work:
yes.jpg
yes.jpg (100.81 KiB) Viewed 1604 times


And this is how it should be connected:
QubinoTemp.jpg
QubinoTemp.jpg (29.91 KiB) Viewed 1604 times
User avatar
stefxx
Advanced Member
Advanced Member
 
Posts: 647
Joined: September 2008
Location: Netherlands


Return to Z-Wave Forum

Who is online

Users browsing this forum: Wim2008 and 1 guest