Everspring AN158-2 - Homeseer issue

Forum and Topics about Z-Wave devices.

Everspring AN158-2 - Homeseer issue

Postby Superhuub » Sun Jan 02, 2011 10:46 am

Can somebody help me with the following issue: I have an Everspring AN158-2 switch and it is correctly added to Homeseer v2.5.0.4. In homeseer a child device with 'electric metering Watts' is showing. At specific interval times the Watt meter is showing a different value. So far so good.

The problem is that I would like to create a trigger in Homeseer based on this value, but I am not able to make it work. Simply the event does not trigger. Other devices than AN158-2 are working right. I really think it is a bug. My workaround is using the BLLogMonitor plugin, but I prefer to use triggers based on values in homeseer.

I hope anybody has an idea.
Superhuub
Starting Member
Starting Member
 
Posts: 21
Joined: December 2010

Re: Everspring AN158-2 - Homeseer issue

Postby Superhuub » Sat Jan 08, 2011 2:09 pm

I have found a solution for this issue! Please leave a message and I will descripe it.
Superhuub
Starting Member
Starting Member
 
Posts: 21
Joined: December 2010

Re: Everspring AN158-2 - Homeseer issue

Postby Bwired » Sat Jan 08, 2011 2:55 pm

Good!
Lets see it
User avatar
Bwired
Administrator
Administrator
 
Posts: 5308
Joined: March 2006
Location: Netherlands

Re: Everspring AN158-2 - Homeseer issue

Postby Superhuub » Sat Jan 08, 2011 8:19 pm

There is a problem with the virtual device 'Electric Meter Watts' device. It has a 'misc settings' which is the cause of the problem, I think.

Look at >status>additional information; it shows here 'no status trigger'. My idea is that it is not possible to use this device as a trigger. Create a new device instead with the same lettercode / unitcode as the 'not working' Electric Meter Watts device. As device type assign 'Status Only'.

You now see two devices and you can now hide the 'not working' Electric Meter Watts device. Create a new event. As trigger type choose 'condition' and select as condition the 'new device' choose an value to test. This works right in my setup with HS 2.5.0.5. Be carefull in my setup 1 Watt is corresponding with value 100.

Additional information:
The AN158-2 reports the power usage every 300 seconds by default. This could be a bit to long for a trigger. You can change the interval time via >status>root device>settings>parameter number. Parameter 3 is by default 30. Changing parameter 3 to 1 shows a 10 seconds interval time, for example.

Happy metering!
Superhuub
Superhuub
Starting Member
Starting Member
 
Posts: 21
Joined: December 2010

Re: Everspring AN158-2 - Homeseer issue

Postby TANE » Sat Jan 08, 2011 9:44 pm

I cant test it now. Since my Aeon is secondary controller at the moment.
Triggering events was possibile what I remember.
you need to add 2 extra zeros.
24 watt
is
2400 for event triggering.

http://blog.tane.nl/?p=199
Enver Tanriverdi | http://blog.tane.nl
User avatar
TANE
Forum Moderator
Forum Moderator
 
Posts: 4806
Joined: April 2007
Location: Netherlands

Re: Everspring AN158-2 - Homeseer issue

Postby Alexander » Mon Jan 10, 2011 12:22 pm

Superhuub wrote:Additional information:
The AN158-2 reports the power usage every 300 seconds by default. This could be a bit to long for a trigger. You can change the interval time via >status>root device>settings>parameter number. Parameter 3 is by default 30. Changing parameter 3 to 1 shows a 10 seconds interval time, for example.


So the lowest value is 10 seconds? That would not be an option for me.
Alexander
Alexander
Global Moderator
Global Moderator
 
Posts: 1532
Joined: March 2007
Location: Netherlands

Re: Everspring AN158-2 - Homeseer issue

Postby Superhuub » Mon Jan 10, 2011 8:28 pm

Yes, 10 seconds is the minimum interval time. The AN158 also supports the 'meter get' command. The manual, page 7 says: "When receiving the meter get command, it will report meter report command to the node of grouping 1". I do not know how to configure this in Homeseer.
Superhuub
Starting Member
Starting Member
 
Posts: 21
Joined: December 2010

Re: Everspring AN158-2 - Homeseer issue

Postby ralhop » Sun Jan 23, 2011 12:03 am

I made a status only device but it still does not work

Reference ID 1103
Status 17 = Unknown
Value 300
String 3 Watts Consumed
Supports Status False
Dimmable False
Misc Settings Status Only


is it also possible to make an event that turn the AN158 off ´when the power is longer then 10 minutes below 10W
Ralph
ralhop
Member
Member
 
Posts: 99
Joined: May 2009
Location: Germany

Re: Everspring AN158-2 - Homeseer issue

Postby Superhuub » Sun Jan 23, 2011 8:40 pm

Hi, My virtual devices shows the same. What is not working? Please provide more details.

"is it also possible to make an event that turn the AN158 off ´when the power is longer then 10 minutes below 10W"

-->> Yes. create again a new virtual device. Create an event when the value of the AN158 (status only device, see above) is lower than 0...1000 and action: switch off the new virtual device. Create a new event when the value is higher then mentioned before and switch on the new virtual device. Create another event which switches off the AN158, when the virtual device is off for at least 10 minutes. I hope it`s clear.
Superhuub
Starting Member
Starting Member
 
Posts: 21
Joined: December 2010

Re: Everspring AN158-2 - Homeseer issue

Postby ralhop » Sun Jan 23, 2011 9:58 pm

what i mean is that my device is still not reacting on a device change event.
I made already different event with diverent values to try but no result.

I want to turn my stereoset turn of when the power is below 10w value 1000
Ralph
ralhop
Member
Member
 
Posts: 99
Joined: May 2009
Location: Germany

Re: Everspring AN158-2 - Homeseer issue

Postby Superhuub » Sun Jan 23, 2011 10:52 pm

Try for example:

Condition
Device: Z-Wave Squeezebox Radio Electric Meter value equals 100
and
Device Command: Z-Wave Squeezebox Radio is On

Action
Device Command: Z-Wave Squeezebox Radio Off

Make sure that the 'current triggertype' is set to "Condition" !
Superhuub
Starting Member
Starting Member
 
Posts: 21
Joined: December 2010

Re: Everspring AN158-2 - Homeseer issue

Postby spanna2000 » Thu Mar 21, 2013 4:02 pm

It wasn't clear to me when reading this if the solution proposed works.

For the avoidance of doubt - it does work! Make a status only device with the same code - use that in a condition and events will trigger based on the value of the device.

My AN158 is now allowing me to sense if my media centre is in TV, Music or Game more by reading it's powerconsumption. From this status I can then power up the associated devices.
spanna2000
Starting Member
Starting Member
 
Posts: 1
Joined: March 2013


Return to Z-Wave Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron