Viessmann Vitodens 100-W with Honeywell ST9520C Programmer

Forum about Opentherm, Hvac, House heating, Boilers

Moderator: hvxl

Viessmann Vitodens 100-W with Honeywell ST9520C Programmer

Postby soylentgreen » Thu Jun 18, 2015 1:17 pm

I have a Viessmann 100-W WB1C system boiler, 4-pipe configuration, with a two-zone heating system controlled by a Honeywell RF2 Pack 5 kit which consists of one Honeywell ST9520C Programmer with built in wireless receiver and two Honeywell DT92e wireless room thermostats.
honeywelluk.com/products/Systems/Wirele ... F2-Pack-5/

I also have the optional Viessmann weather sensor connected, while the hot water system and controls are yet to be installed, but this should not have any bearing on the problem.

Because of my custom heating system design I require the CH LIMIT parameter i.e. boiler's central heating output temperature, set within the programmer's OpenTherm Setup, to be 60°C. In normal circumstances the system works excellently, with the CH LIMIT remaining at 60°C and the room temperature held very accurately, with possibly the weather sensor causing a very occasional very slight overshoot on very sunny but very cold winter days (the house has large south facing windows and the weather sensor is on the north side), but that is not the issue I'm concerned with.

The key problem arises when there is a power cut. Just one parameter in the programmer changes, which is that the CH LIMIT changes from my chosen set point of 60°to 80°C. Tests show that the default CH LIMIT temperature is 90°C if OpenTherm is disabled at the programmer, and further tests show that the parameter is not lost if the boiler alone is rebooted, nor if the programmer alone is rebooted, only if they are simultaneously powered down.

Viessmann Technical insist it cannot be a problem with their boiler. After I changed the backup button memory cell in the programmer to no avail I contacted Honeywell who promptly exchanged the programmer but unfortunately the replacement behaved in exactly the same way, since when Honeywell UK has been 'looking into the problem' and will contact Honeywell Netherlands. I note that Viessmann UK are marketing a rebadged Honeywell CM737 single zone 7-day programmable room thermostat as a Viessmann branded unit, part no. ZK01041, having tested it as compatible with their boilers.

It appears from my tests that I could fit a dedicated Uninterrupted Power Supply (UPS) to the Honeywell programmer to resolve the issue, but does anyone have any idea why this problem is occurring, must it be due to a bug in the Honeywell programmer rather than the Viessmann boiler and is a UPS the simplest and cheapest solution should Honeywell fail to provide a remedy?
soylentgreen
Starting Member
Starting Member
 
Posts: 1
Joined: June 2015

Return to Hvac, Heating Opentherm Forum

Who is online

Users browsing this forum: No registered users and 1 guest