otlog ATAG

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

otlog ATAG

Postby mmaz » Wed May 15, 2019 10:54 pm

Dear all,
I am looking for someone who has an otlog of the first messages exchanged between thermostat and ATAG boiler.
I have an ATAG boiler model Q15S, which supports z-ready protocol (opentherm by ATAG) but it is not present inside the compatibility matrix (http://otgw.tclcode.com/matrix.cgi#boilers).
I have no thermostat and I am guessing if the boiler needs some special commands before starting to reply correctly.
I built my own interface attached to an esp8266 and I got always "DATA-INVALID" or "UNKNOWN-DATAID" from boiler.
For instance:

TX: 0x00000000
RX: 0x60000000

TX: 0x80020000
RX: 0x70020000

TX: 0x00030000
RX: 0x60030000

TX: 0x80190000
RX: 0xe0190000

TX: 0x00390000
RX: 0x60390000

TX: 0x80380000
RX: 0xe0380000

Thanks in advance for any help.
mmaz
Starting Member
Starting Member
 
Posts: 7
Joined: January 2016

Re: otlog ATAG

Postby mmaz » Fri Jun 07, 2019 9:16 pm

Nobody has contacts with the owners of ATAG boilers?
I found someone inside old forum posts, but they are not visiting it anymore and neither replied to my direct mails.
Thanks to everyone who can help me,
Michele.
mmaz
Starting Member
Starting Member
 
Posts: 7
Joined: January 2016

Re: otlog ATAG

Postby hvxl » Fri Jun 14, 2019 10:53 am

The logs that were uploaded for the Atag Wize thermostat don't show any unusual messages. Although, if Atag is actively shutting out any Opentherm thermostats other than their own, the boiler may be checking the Master configuration information. A Wize reports this as 00000001 48 (90020130).

But to me this sounds more like the boiler may not be operating in Opentherm mode. It may have decided that when it started and didn't see an Opentherm thermostat within a certain amount of time. You could try to remove the power from the boiler for a minute and then power it up again with the OTGW connected.

The installation manual also mentions a few parameters that may influence which type of communication the boiler uses. At least parameter 60 (Communication bus type) and 89 (Address selection) seem relevant. It sounds to me that 02 would be the best setting for parameter 60 for you, and 89 may possibly need to be -01. You can experiment with those settings.
Schelte
hvxl
Senior Member
Senior Member
 
Posts: 1180
Joined: June 2010

Re: otlog ATAG

Postby mmaz » Sat Jun 15, 2019 9:17 am

Thank you very much,
I will try asap.
Michele.
mmaz
Starting Member
Starting Member
 
Posts: 7
Joined: January 2016

Re: otlog ATAG

Postby mmaz » Sun Jun 16, 2019 10:35 pm

Thank you very much Schelte!
The msg you reported has made the difference.
Now the boiler replies to my request with WRITE-ACK, READ-ACK or UNKNOWN-DATAID; instead of DATA-INVALID:

TX: 0x90020130
RX: 0x50020130 (WRITE-ACK)

TX: 0x00000000
RX: 0x40000002 (READ-ACK)

TX: 0x00030000
RX: 0xc0030102 (READ-ACK)

TX: 0x80190000
RX: 0x40193f00 (READ-ACK)

TX: 0x80380000
RX: 0x70380000 (UNKNOWN-DATAID)

TX: 0x00390000
RX: 0xc0392d00 (READ-ACK)

Now I can start to control my boiler!

Regards,
Michele.
mmaz
Starting Member
Starting Member
 
Posts: 7
Joined: January 2016


Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest