Please add output of PS=1 to otmonitor webpage

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

Please add output of PS=1 to otmonitor webpage

Postby ThinkPad » Mon Nov 09, 2015 9:41 pm

Would it be possible to let the 'command' page display output of the PS=1 command?

Now it doesn't work when i call http://localhost:8080/command?PS=1
It shows the output of PS=1 in the otmonitor log, but unfortunately not in the webpage output, it only shows PS=1 again....

When showing the output from PS=1 also on the webpage output, i could scrape the contents much easier with something like a PHP-script and store it in my own application stuff. For now the only option seems to be to open a socket to the OTGW directly, which is much more work and quite difficult, especially when the OTGW is connected to a different physical machine.

Please add this option if possible :D
User avatar
ThinkPad
Member
Member
 
Posts: 75
Joined: November 2014

Re: Please add output of PS=1 to otmonitor webpage

Postby timoline » Tue Nov 10, 2015 6:55 pm

I'm not sure it shows the info you want....but maybe you can use the json output?
http://<ip>:<port>/json
timoline
Starting Member
Starting Member
 
Posts: 33
Joined: November 2015

Re: Please add output of PS=1 to otmonitor webpage

Postby ThinkPad » Tue Nov 10, 2015 9:19 pm

timoline wrote:I'm not sure it shows the info you want....but maybe you can use the json output?
http://<ip>:<port>/json

That's perfect, thank you very much!

Too bad that such things are not documented at all @ the official website... would have saved quite some time if i found this out earlier.
User avatar
ThinkPad
Member
Member
 
Posts: 75
Joined: November 2014

Re: Please add output of PS=1 to otmonitor webpage

Postby hvxl » Tue Nov 10, 2015 10:41 pm

Agreed, the documentation at the web site is horrible and incomplete. I might just as well shut it down.
Schelte
hvxl
Senior Member
Senior Member
 
Posts: 1103
Joined: June 2010

Re: Please add output of PS=1 to otmonitor webpage

Postby timoline » Wed Nov 11, 2015 8:38 pm

yes please shut it down...it's rubbish...

Ok,now serious....you did/do an amazing job by making this all possible, great great great respect :!:
timoline
Starting Member
Starting Member
 
Posts: 33
Joined: November 2015


Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest