Page 1 of 1

OTGW stopped working, many Error 03s

PostPosted: Wed Jan 06, 2016 11:55 am
by nickyb2

I have a simple setup. iSense v28, OTGW 4.2.5, Remeha Avanta. The OTGW is hooked up to a rPI through USB.

The rPI runs the otmonitor software and has been running fine for weeks, until about 3 days ago. When i 'view' the messages tab, all i see are Error 03. When i switch the OTGW to monitor mode the Error 03's dissapear and if i understood the documentation correctly it has something to do with the firmware. If i reload the firmware (4.2.5) the OTGW works again for a few minutes up to an hour or so and then error 03's again.

Does any have any ideas, pointers or advice on what might be wrong?

Thanks in advance,

Re: OTGW stopped working, many Error 03s

PostPosted: Wed Jan 06, 2016 9:34 pm
by hvxl
As the troubleshooting instructions indicate, the first thing to do in case of Error 03's is to try different settings for the reference voltage.

Re: OTGW stopped working, many Error 03s

PostPosted: Wed Jan 06, 2016 11:44 pm
by Dylantje
As the troubleshooting instructions indicate, the first thing to do in case of Error 03's is to try different settings for the reference voltage.

How can i do that?

Re: OTGW stopped working, many Error 03s

PostPosted: Thu Jan 07, 2016 12:05 am
by hvxl
Via one of the methods mentioned there.

Re: OTGW stopped working, many Error 03s

PostPosted: Thu Jan 07, 2016 7:05 am
by nickyb2
I'll hook the OTGW up again today to test with a different voltage setting.

Before i do that can you explain why i need a different voltage setting? It's been running fine for weeks on setting 3 (default), why would it suddenly need a different voltage setting?

Re: OTGW stopped working, many Error 03s

PostPosted: Fri Jan 08, 2016 10:04 am
by Bororo
I see the same behaviour. My OTGW was built 2 years ago, then 1 year waiting in the shelf and now, after aprox. 1 year of real usage (24x7) I see thousands Error 3 messages in the log. I have no idea what is causing this, but it looks like some component are getting older and voltage is not so stable as when new.

Re: OTGW stopped working, many Error 03s

PostPosted: Fri Jan 08, 2016 8:14 pm
by tjibbebuijsman
I have the same problem since last week. Also connected to a Remeha Avanta, but with a Honeywell Round thermostat. Since it was getting cold in my house, I checked my Domoticz setup running on a raspberry with the OTGW connected through USB.
there were a lot of Error 03's in the log. when I connected the OTGW to my laptop and running from windows, just the same error. However, when I put the OTGW in monitor mode, it reads all values correctly....?!?
I followed the troubleshooting page, but all voltages seem OK. when I reconnected at first I did get the Error 03 again. Then I tried re-wiring the thermostat and the boiler and suddenly it starts working again, for a day or shorter.
I don't understand what's going wrong.... but since the monitor mode works, it looks like a firmware problem.

I did attach the log file, which today shows I did rewiring the thermostat and boiler and even for a second the connection worked... anybody know how to solve?

Re: OTGW stopped working, many Error 03s

PostPosted: Mon Mar 14, 2016 11:03 am
by markieman
I'd like to continue on this thread. I'm seeing similar issues.

My OTGW is running perfectly fine for 3 months now (In the middle of an Intergas boiler and a Honeywell Round Modulation Thermostat)
Just 0-3 'Error 03' messages per day.

There is just a weird 'Error 03' thing going on.
In those 3 months, it happend 4 times that the gateway just started spitting out a lot of 'Error 03' warnings, causing the Thermostat to display an 'F'

The first three times I tried rebooting, disconnecting and reconnecting power but with little success.
Changing Ref voltage does nothing, even makes it worse.

I removed the OTGW al together because of a lack of time of throubleshooting and the Thermostat and boiler worked fine again.
Next day, reconnect OTGW, and again, it worked beautifully.

The last time, I just waited, let the OTGW spit out about 6000 'Error 03' messages in a few hours, before it continued working as normal all on its own!.

I have a custom setup, OTGW directly connected to an Arduino and in the end all data is dumped in a SQL Database.

The 'Error 03' is alternated with valid OT messages, mostly with ID = 9. And in the few hours I can see the gateway rebooted itself about ~12 times.

I'm not into electronics at all (Software Dev), but i'm trying to learn.
A colleague who knows something about electronics, suggested that the cause may be bad solder joins, so i will look into that, but it could also be that the Voltage Regulator is osscilating or overheating.
He pointed out that the regulator is missing two small ceramic capacitors as stated in the datasheet which may solve the issue.

Before I order something or destroy something, I want to check if he is thinking in the right direction, or if I have to look somewhere else.

Re: OTGW stopped working, many Error 03s

PostPosted: Thu Mar 24, 2016 5:07 pm
by hvxl
It would have been helpful if you had included a reference to your (colleague's) claim about the datasheet. The datasheets I consulted do not mention any ceramic capacitors for preventing oscillation or overheating. There's only a reference to capacitors in the "typical applications" section (notice that the section is not called "mandatory external components" or something like that): "Ci is required if regulator is located an appreciable distance from power supply filter." While that's a bit vague, the regulator is right next to C1, which doesn't seem like an "appreciable distance" to me. "Co improves stability and transient response." The current drawn should be quite steady, so there's not much of a transient response to improve. Nevertheless, there's C2 to handle that.

I'm aware that ceramic capacitor react faster than electrolytic ones, so it may be beneficial in some applications to add ceramic capacitors to either side of the voltage regulator, but I give it a very low chance of solving the problems you mention. On the other hand it also won't hurt the operation of the circuit, so go right ahead and add those capacitors. However, I don't think the power supply is the cause of the trouble, unless you're not using a TO220 version as suggested, or you power additional equipment from it that it was not designed for (like the Arduino).

Your interpretation of the log in prose form is also not as useful as a piece of the actual log would have been. I get the impression that messages from the thermostat are received correctly, but the responses from the boiler are not. In that case there is usually very little gain to be expected from changing Vref. Most likely the opto-couplers are distorting the signal. When you get the errors, you can try to switch the gateway to monitor mode and see if that clears up the F on the display of the thermostat. You can also check the delay symmetry of the opto-couplers using the diagnostic firmware.

Re: OTGW stopped working, many Error 03s

PostPosted: Mon Apr 04, 2016 8:03 pm
by markieman
Tnx for your time and feedback.

Well, my colleague did only reference the typical applications diagram; and based his claim on electronics experience,
He acknowlegded it was just speculation, so i decided to put both my question and this suggestion in my post.
Since both of you basicly said they could do no harm, i just added the capacitors. You are probably right that they have no effect.

In the mean time, i've been logging full time, but haven't seen the errors bursts since.

I did however manage to convert my logging into something similar to what otmoniter writes out, and posted it as an attachment.
Also ran diagnostisc, which i also included in full. Most look ok to me, however test #4 may have some odd values (i'm not sure what the tolerance are):

OK1A high-to-low: 10us
OK1A low-to-high: 16us
OK1B high-to-low: 5us
OK1B low-to-high: 6us

Another odd thing I noticed was that after reinstalling the firmware, for the first few minutes, (almost) any Ref Voltage worked, except for the default.
After a while, VR=4 is accepted. The log where you can see me playing around with VR is also included.

Any feedback or help on how to approach this is appreciated.

Re: OTGW stopped working, many Error 03s

PostPosted: Fri Apr 08, 2016 1:19 pm
by hvxl
The diagnostics all look good. The high-to-low and low-to-high transitions of each opto-coupler are reasonably close. The difference between the two opto-couplers is not relevant.

The logs show that during the times when you have problems you don't get an error response to each message. This gives the impression that the boiler doesn't receive/understand all messages, in which case it doesn't send a response. And when it does, the gateway doesn't understand that response. So you seem to have problems in both directions at certain times, while at other times communication works perfectly in both directions.

I agree with your colleague that this sounds like a bad contact somewhere. Opentherm uses the same two wires for communication in both directions, so a bad contact could easily affect both directions. However, inside the OTGW, the two paths are split up fairly quickly. A problem past that point wouldn't affect both directions. That limits the area where a bad contact would cause the symptoms you describe. It's either in the cable between the OTGW and the boiler, or the circuitry around X2, D5-D10, Q1, R1-R3.

The first simple thing you can try is to swap the wires of the cable connected to X2. Depending on which wire is + and -, the signal goes through either D8 and D5 or through D7 and D6. If that doesn't change the symptoms, you can rule out D5-D8 (unless you have multiple identical bad contact). Next, try a different cable between the boiler and the gateway. If that also doesn't help, recheck the solder joins of X2, Q1, D9, D10, R1, R2, and R3. Since those are only a limited number of components you may even want to just resolder them.