Opentherm connected to ESP8266

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

Opentherm connected to ESP8266

Postby bryan241 » Thu Feb 04, 2016 7:25 pm

Hi All,

I've connected an esp8266 to the opentherm gateway which functions as a serial to wifi bridge.
This works perfectly for 24 hours now.

My question is more related to powering the esp.
the esp requires max 240ma (3v3). I have a level shifter in between the esp and the opentherm gateway.

Is it possible to power the esp from the internal opentherm power supply?
The 7805 needs to be cooled for sure, but can the transformer deliver enough power for the opentherm gateway and the esp?

Regards,

Bryan
bryan241
Starting Member
Starting Member
 
Posts: 7
Joined: November 2014

Re: Opentherm connected to ESP8266

Postby adijk » Fri Feb 05, 2016 1:48 pm

adijk
Starting Member
Starting Member
 
Posts: 18
Joined: December 2013

Re: Opentherm connected to ESP8266

Postby Bwired » Fri Feb 05, 2016 1:57 pm

Nice
can you post a small schematic (with partsnr) how you connected the ESP?
would be great!
User avatar
Bwired
Administrator
Administrator
 
Posts: 5300
Joined: March 2006
Location: Netherlands

Re: Opentherm connected to ESP8266

Postby bryan241 » Fri Feb 05, 2016 8:07 pm

Thanks for the great reference post. (why didn't I find this while searching through the old posts?)
I've ordered a replacement transformer and dc-dc converter.

For testing Ive used a chinese 220v to 5v power supply, like this one: http://www.ebay.com/itm/HLK-PM01-AC-DC- ... 1932592389
Not exactly the same because my model is not sold anymore, probably for a reason...

I'm using http://www.dx.com/p/esp-12-esp8266-seri ... rTxDU9fRdg as the esp.
loaded with serial bridge firmware. tx connected to rx on otgw and rx to tx.
Connected grounds to each other and connected +5 from the chinese power adapter to the esp.
Works great for 36 hours now.

Regards,
Bryan
bryan241
Starting Member
Starting Member
 
Posts: 7
Joined: November 2014

Re: Opentherm connected to ESP8266

Postby stoffel67 » Fri Apr 29, 2016 10:53 am

Hello,
I have connected a ESP8266 to my OTGW too.
( I replaced the 7805 with RECOM R-78E5.0-0.5, the ESP8266 is powered with LF33CV,
and between PIC and ESP8266 I use a Levelshifter for the data lines)

I see all the replies from the OTGW in the Log
...
T901815A4
T80000100
T10149233
...
but when I try to "send" Free Format command" like "PR=B"
the command is sent( in the Log),
but I do not get repsonse from the PIC in the Log
so, it seems nothing is sent to the PIC...?

I have tested the ESP8266 with Connection to PC( WLAN and USB-TTL), and it works perfect in both directions...

Any hints where to search?

Regards
Stef
stoffel67
Starting Member
Starting Member
 
Posts: 3
Joined: April 2016

Re: Opentherm connected to ESP8266

Postby vadimber » Tue Apr 25, 2017 5:52 pm

Hello,

If you firstly connect to power OTGW and after that connect ESP to OTGW it works, but there are some side effects...

When I use OTGW with upgraded parts for supply ESP8266 (serial bridge https://ru.aliexpress.com/item/Serial-W ... 0.0.V0PEGu with 5V->3.3V on board converter), Otmonitor regularly receives "E" "SE" errors from OTGW is such setup, see log below in "PS=1" mode. There are no any errors when I directly connect OTGW to my Notebook throw USB cable

log sample:
11:41:15.283083 E
11:41:15.503945 E
11:41:15.621174 E
11:41:15.742293 E
11:41:15.859102 E
11:41:16.015367 E
11:41:16.058062 SE
11:41:16.187271 E
11:41:16.303038 E
11:41:16.419744 E
11:41:16.537263 E
11:41:16.658378 E

Do you have any ideas?

Thank you!
Vadim
vadimber
Starting Member
Starting Member
 
Posts: 1
Joined: April 2017


Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest