OTGW hangs with WDT reset!

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

Re: OTGW hangs with WDT reset!

Postby sincze » Mon Dec 11, 2017 11:40 am

hvxl wrote:The changes between version 4.2.3 and 4.2.5 are very small. I don't see anything in there that seems like it could have introduced a reason for a WDT reset.


I have to admit. The WDT reset is back even with 4.2.3 firmware.
It started last week with 4.2.5 and now with 4.2.3 as well.

Any solutions?

Only thing I can do is replace the OTGW with a spare one to see if this fixes the problem.
screenshot_otgw.JPG
OTGW
screenshot_otgw.JPG (113.46 KiB) Viewed 822 times
sincze
Starting Member
Starting Member
 
Posts: 35
Joined: June 2014
Location: Breda

Re: OTGW hangs with WDT reset!

Postby sincze » Tue Jan 02, 2018 2:34 pm

Since october last year I had some problems with the OTGW.
In addition when monitoring the performance of the central-heating system I did see some strange things regarding the boiler temperature suddenly dropping.
The result was sometimes no hot water after 5 minutes, and in addition WDT Resets with no root cause mentioned in the log.

I automated the reset switch but this is ofcourse no solution.
In the end around Christmas we had a broken pump.

A guy came over to fix it and he also noticed the rootcause problem of the cold water after 5 minutes.
He replaced the pump and several new boiler sensors. After that no more WDT Reset,
Strange or what?

Could it be, and I already attached the log files earlier that OTGW Firmware receives 'corrupt' data from the boiler sensor and crashes with a WDT Reset no cause?
sincze
Starting Member
Starting Member
 
Posts: 35
Joined: June 2014
Location: Breda

Previous

Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest