OTGW hangs with WDT reset!

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

Re: OTGW hangs with WDT reset!

Postby sincze » Mon Dec 11, 2017 11:40 am

hvxl wrote:The changes between version 4.2.3 and 4.2.5 are very small. I don't see anything in there that seems like it could have introduced a reason for a WDT reset.


I have to admit. The WDT reset is back even with 4.2.3 firmware.
It started last week with 4.2.5 and now with 4.2.3 as well.

Any solutions?

Only thing I can do is replace the OTGW with a spare one to see if this fixes the problem.
screenshot_otgw.JPG
OTGW
screenshot_otgw.JPG (113.46 KiB) Viewed 3011 times
sincze
Starting Member
Starting Member
 
Posts: 38
Joined: June 2014
Location: Breda

Re: OTGW hangs with WDT reset!

Postby sincze » Tue Jan 02, 2018 2:34 pm

Since october last year I had some problems with the OTGW.
In addition when monitoring the performance of the central-heating system I did see some strange things regarding the boiler temperature suddenly dropping.
The result was sometimes no hot water after 5 minutes, and in addition WDT Resets with no root cause mentioned in the log.

I automated the reset switch but this is ofcourse no solution.
In the end around Christmas we had a broken pump.

A guy came over to fix it and he also noticed the rootcause problem of the cold water after 5 minutes.
He replaced the pump and several new boiler sensors. After that no more WDT Reset,
Strange or what?

Could it be, and I already attached the log files earlier that OTGW Firmware receives 'corrupt' data from the boiler sensor and crashes with a WDT Reset no cause?
sincze
Starting Member
Starting Member
 
Posts: 38
Joined: June 2014
Location: Breda

Re: OTGW hangs with WDT reset!

Postby sincze » Sun Feb 18, 2018 9:12 pm

Let me answer my own question :) .. that would be a NO.
Still experiencing random resets..... and hangs...
As I have automated the reset... it will reboot the OTGW after 5 minutes and it continues to work.
This happens around 7 times a day.


Code: Select all
2018-02-18 20:55:20.349  (GW OpenTherm) Temp (Max.  Vloerverwarming)
2018-02-18 20:55:20.367  (GW OpenTherm) General/Percentage (Maximum Relative Modulation Level)
2018-02-18 20:55:20.378  (GW OpenTherm) Thermostat (Room Setpoint)
2018-02-18 20:55:20.389  (GW OpenTherm) General/Percentage (Relative modulation level)
2018-02-18 20:55:20.401  (GW OpenTherm) General/Pressure (CH Water Pressure)
2018-02-18 20:55:20.429  (GW OpenTherm) Temp (Room Temperature)
2018-02-18 20:55:20.441  (GW OpenTherm) Temp (Boiler Water Temperature)
2018-02-18 20:55:20.458  (GW OpenTherm) Temp (DHW Temperature)
2018-02-18 20:55:20.465  (GW OpenTherm) Temp (OTGW - Outside Temperature)
2018-02-18 20:55:20.472  (GW OpenTherm) Temp (Return Water Temperature)
2018-02-18 20:55:20.489  (GW OpenTherm) Thermostat (DHW Setpoint)
2018-02-18 20:55:20.495  (GW OpenTherm) Thermostat (Max_CH Water Setpoint)
....
2018-02-18 20:55:37.356  OTGW: OpenTherm Gateway 4.2.5
2018-02-18 20:55:37.356  OTGW: WDT reset!
....
2018-02-18 21:03:58.986  User: Admin initiated a switch command (1375/OTGW Reset/Off)
2018-02-18 21:03:59.792  (GW MySensors LAN) Light/Switch (OTGW Reset)
2018-02-18 21:04:00.457  OTGW: OpenTherm Gateway 4.2.5
2018-02-18 21:04:00.457  OTGW: T00390000
....
2018-02-18 21:04:01.457  OTGW: B40393200
2018-02-18 21:04:01.458  OTGW: T80190000
....
2018-02-18 21:04:20.474  (GW OpenTherm) Lighting 2 (OTGW_DHW_active)
2018-02-18 21:04:20.483  (GW OpenTherm) Temp (Max.  Vloerverwarming)
2018-02-18 21:04:20.489  (GW OpenTherm) General/Percentage (Maximum Relative Modulation Level)
2018-02-18 21:04:20.495  (GW OpenTherm) Thermostat (Room Setpoint)
2018-02-18 21:04:20.499  (GW OpenTherm) General/Percentage (Relative modulation level)
2018-02-18 21:04:20.510  (GW OpenTherm) Temp (Room Temperature)
2018-02-18 21:04:20.517  (GW OpenTherm) Temp (Boiler Water Temperature)
2018-02-18 21:04:20.523  (GW OpenTherm) Temp (DHW Temperature)
2018-02-18 21:04:20.534  (GW OpenTherm) Temp (OTGW - Outside Temperature)
2018-02-18 21:04:20.539  (GW OpenTherm) Temp (Return Water Temperature)
2018-02-18 21:04:20.561  (GW OpenTherm) Thermostat (Max_CH Water Setpoint)

sincze
Starting Member
Starting Member
 
Posts: 38
Joined: June 2014
Location: Breda

Re: OTGW hangs with WDT reset!

Postby mrten » Mon May 07, 2018 7:21 pm

I'm having the exact same problem (WDT reset immediately after startup) after a year of no problems, so I'm wondering whether we're looking at a power supply/hardware problem.
mrten
Starting Member
Starting Member
 
Posts: 2
Joined: May 2018

Re: OTGW hangs with WDT reset!

Postby sincze » Tue May 08, 2018 6:45 am

mrten wrote:I'm having the exact same problem (WDT reset immediately after startup) after a year of no problems, so I'm wondering whether we're looking at a power supply/hardware problem.


Immediately after startup. MMM probably not exact the same thing as mine runs well for an amount of time.
As there was no reason mentioned for the reset I was thinking about HW failure somewhere as well and as it resets the PIC or voltage had my attention.

I changed the PIC with help of Kiwi Electronics and the problem was gone for 1 week, So thrilled.... but
After that I had a random lock up once every 1-3 days.
But now it has been weeks (so it still happens but not that much).
BUT it is getting warmer outside and the Heating unit does not have to do that much. So it still could be something the heater does...
Warmer.... -> weeks no reset.
As I've automated the reset switch i can monitor this exacty with Domoticz and I receive a Telegram message.

I also ordered a R-78E5.0-0.5 DC/DC-converter but did not mount it yet. I guess we will have to wait.

In my domoticz log I do see a 'restart' of the pic of some sort.. But it does not hang.
Code: Select all

2018-05-08 02:43:07.367  OTGW: OpenTherm Gateway 4.2.5
2018-05-08 05:52:39.156  OTGW: OpenTherm Gateway 4.2.5

2018-05-07 00:14:25.401  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 02:43:23.376  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 06:00:00.946  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 07:30:11.508  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 09:34:33.210  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 12:22:35.509  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 14:04:23.588  OTGW: OpenTherm Gateway 4.2.5
2018-05-07 23:49:34.196  OTGW: OpenTherm Gateway 4.2.5

2018-05-06 00:34:58.832  OTGW: OpenTherm Gateway 4.2.5
2018-05-06 04:23:20.976  OTGW: OpenTherm Gateway 4.2.5
2018-05-06 08:30:19.378  OTGW: OpenTherm Gateway 4.2.5
2018-05-06 20:21:52.997  OTGW: OpenTherm Gateway 4.2.5
sincze
Starting Member
Starting Member
 
Posts: 38
Joined: June 2014
Location: Breda

Re: OTGW hangs with WDT reset!

Postby rpav » Tue May 08, 2018 8:13 am

Unfortunately, my OTG has the same problem:
Code: Select all
14:45:57.278123  BE0800000  Data-Inv    Message ID 128: 0
14:45:57.948281  T90822B41  Write-Data  Message ID 130: 11073
14:45:58.265103  B50822B41  Write-Ack   Message ID 130: 11073
14:45:58.938299  T00300000  Read-Data   DHW setpoint boundaries: 0 0
14:45:59.253963  BC030410A  Read-Ack    DHW setpoint boundaries: 65 10
14:45:59.925079  T80000200  Read-Data   Status: 00000010 00000000
14:46:00.247648  B40000200  Read-Ack    Status: 00000010 00000000
14:46:00.915342  T10010A00  Write-Data  Control setpoint: 10.00
14:46:01.148033  800000
14:46:01.159393  0800000
14:46:01.167420  0822B41
14:46:01.174990  0822B41
14:46:01.186770  0300000
14:46:01.194276  030410A
14:46:01.201898  0000200
14:46:01.213904  0000200
14:46:01.223649  0010A00
14:46:01.286453  800OpenTherm Gateway 4.2.5
14:46:01.298781  WDT reset!
15:51:00.346210  2B41
15:51:00.357083  0822B41
15:51:00.365920  0300000
15:51:00.374734  030410A
15:51:00.384915  0000200
15:51:00.411066  000enTherm Gateway 4.2.5
15:51:00.421236  WDT reset!
15:51:00.434804  2B41
15:51:00.438568  0822B41
15:51:00.446937  0300000
15:51:00.458958  030410A
15:51:00.466554  0000200
15:51:00.501226  000enTherm Gateway 4.2.5
15:51:00.505001  WDT reset!
15:51:00.519685  2B41
15:51:00.521538  0822B41
15:51:00.529922  0300000
15:51:00.546319  030410A
15:51:00.550150  0000200
15:51:00.575159  000enTherm Gateway 4.2.5
15:51:00.588378  WDT reset!
15:51:00.600757  2B41
15:51:00.604970  0822B41
17:27:01.584122  Command (via websocket from 192.168.123.233:57238): W
17:27:26.628946  Command (via websocket from 192.168.123.233:57236): GW=R


It appears for the first time after more then one year without any problem...
rpav
Starting Member
Starting Member
 
Posts: 25
Joined: November 2015

Re: OTGW hangs with WDT reset!

Postby hvxl » Mon May 14, 2018 4:52 pm

Interesting that the serial output starts to break up before the WDT reset. The reset does not clear that up, which I would expect if the problem was due to the OTGW getting into some strange state after a while. This does suggest that the problem is caused by something external to the PIC. Perhaps the power supply or the USB-serial device, as mrten speculated.
Schelte
hvxl
Senior Member
Senior Member
 
Posts: 1105
Joined: June 2010

Re: OTGW hangs with WDT reset!

Postby rpav » Wed Jun 06, 2018 8:54 am

Unfortunately, OTG frozen again. It does not respond Reset command.
Is there any way how to trace the bug now or should I just perform HW reset and go on?


Code: Select all
08:04:54.689785  T10181644  Write-Data  Room temperature: 22.27
08:04:54.958446  BD0181644  Write-Ack   Room temperature: 22.27
08:04:55.678303  T80800000  Read-Data   Message ID 128: 0
08:04:55.948332  BE0800000  Data-Inv    Message ID 128: 0
08:04:56.668036  T90825341  Write-Data  Message ID 130: 21313
08:04:56.936557  B50825341  Write-Ack   Message ID 130: 21313
08:04:57.657660  T907E0101  Write-Data  Master product version: 1 1
08:04:58.123783  B507E0101  Write-Ack   Master product version: 1 1
08:04:58.643774  T00000000  Read-Data   Status: 00000000 00000000
08:04:58.916142  BC0000000  Read-Ack    Status: 00000000 00000000
08:04:59.637445  T10010A00  Write-Data  Control setpoint: 10.00
08:04:59.904641  BD0010A00  Write-Ack   Control setpoint: 10.00
08:05:00.675800  T10080A00  Write-Data  Control setpoint 2: 10.00
09:19:01.044030  Command (via websocket from 192.168.123.1:48465): GW=R
rpav
Starting Member
Starting Member
 
Posts: 25
Joined: November 2015

Re: OTGW hangs with WDT reset!

Postby mrten » Wed Oct 03, 2018 9:44 pm

Has anybody configured sending of mails when a WDT reset occurs? I have (so I get a nice email every time it resets), but I've also set up warning mails for too high and too low a pressure and temperature.

So, besides the WDT reset mails, I see mails like these:

Code: Select all
The room temperature has dropped below 14 degrees. The current room temperature is 3.72 degrees.
The CH water pressure has dropped below 1.5 bar. The current CH water pressure is -127.70 bar.
The CH water pressure has dropped below 1.5 bar. The current CH water pressure is -63.99 bar.
The CH water pressure has risen above 2.5 bar. The current CH water pressure is 31.00 bar.
The room temperature has dropped below 14 degrees. The current room temperature is -107.80 degrees.

I'm pretty sure that it did not get that cold in my living room, the pressures are also pretty out of whack :)

Is this a possible hint towards the problem?

I also have two programs sending messages simultaneously to the OTGW, perhaps a buffer overflow of some sort? I'll try to combine them to see if the problem goes away.

(one sends PM=28 every 37 seconds, the other pokes the outside temperature from Weather Underground with OT=..)

Maarten.
mrten
Starting Member
Starting Member
 
Posts: 2
Joined: May 2018

Re: OTGW hangs with WDT reset!

Postby sincze » Fri Oct 05, 2018 3:32 pm

A yes strange things happen indeed.

Well after changing the PIC last year I incidently had WDT resets that needed to be reset by resetting the PIC.
Honestly I did not look at my logs either as I thought hey... no warning no problem.

Recenthly I had the yearly inspection so I disconnected the OTGW (I've used RCA plugs as connectors so that is an easy job) as most of these guys just don't like external equipment being connected.
It might interfere with their work. And they give me some examples that I can imagine.

He cleaned the whole installation and did not see any obvious problems.
After completion of his work I showed him what the OTGW could do and he was amazed by the graphs.

The next day I started to witness WDT resets again. Not once every x weeks but now back at 7 WDT PIC resets a day.
But it is getting colder outside as well. Still no clue why this happens. The automatic PIC reset does bring the device back on line.

Code: Select all
2018-10-05 12:26:40.659  Status: User: Admin initiated a switch command (75/OTGW Reset/On)
2018-10-05 12:26:41.882  Status: User: Admin initiated a switch command (75/OTGW Reset/Off



My Domoticz log shows a working OTGW with data ... then it says WDT reset.
I connect domoticz to the OTGW via Ser2net, that could be a connection renewal issue. (Port already in use)
As domoticz does not receive valid data it will reset the 'hardware device within domoticz'

After a pic reset by domoticz as described above Reset/On, most obvious the ser2net connection is killed and can be successfully rebuild -> I receive data again.
I could try experimenting what will happen if I don't have Domoticz reset its hardware device. Maybe I just notice a WDT Reset,,, but the PIC does not need the reset. I'll let you know,

Code: Select all
2018-10-05 12:17:44.565  (GW OpenTherm) Thermostat (DHW Setpoint)
2018-10-05 12:17:44.576  (GW OpenTherm) Thermostat (Max_CH Water Setpoint)
...
2018-10-05 12:18:04.519  Status: OTGW: OpenTherm Gateway 4.2.5
2018-10-05 12:18:04.519  Status: OTGW: WDT reset!
..
2018-10-05 12:19:00.136  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:19:01.137  Error: Restarting: GW OpenTherm
2018-10-05 12:19:01.546  Status: OTGW: TCP/IP Worker stopped...
2018-10-05 12:19:03.551  Status: OTGW: connected to: 192.168.**.**:****
2018-10-05 12:20:30.007  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:20:31.008  Error: Restarting: GW OpenTherm
2018-10-05 12:20:33.578  Status: OTGW: connected to: 192.168.**.**:****
2018-10-05 12:20:33.578  Status: OTGW: Port already in use
2018-10-05 12:20:33.579  Status: OTGW: Connection reset!
2018-10-05 12:20:33.579  Status: TCP: Reconnecting in 30 seconds...
2018-10-05 12:21:30.007  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:22:00.623  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:22:01.640  Error: Restarting: GW OpenTherm
2018-10-05 12:23:30.694  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:23:31.694  Error: Restarting: GW OpenTherm
2018-10-05 12:23:32.677  Status: OTGW: TCP/IP Worker stopped...
2018-10-05 12:23:34.678  Status: OTGW: connected to: 192.168.**.**:****
2018-10-05 12:25:01.130  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:25:02.131  Error: Restarting: GW OpenTherm
2018-10-05 12:26:30.749  Error: GW OpenTherm hardware (11) nothing received for more than 1 Minute!....
2018-10-05 12:26:31.749  Error: Restarting: GW OpenTherm
2018-10-05 12:26:32.734  Status: OTGW: TCP/IP Worker stopped...
2018-10-05 12:26:34.735  Status: OTGW: connected to: 192.168.**.**:****
2018-10-05 12:26:34.735  Status: OTGW: Port already in use
2018-10-05 12:26:34.735  Status: OTGW: Connection reset!
2018-10-05 12:26:34.735  Status: TCP: Reconnecting in 30 seconds...
2018-10-05 12:26:40.659  Status: User: Admin initiated a switch command (75/OTGW Reset/On)
2018-10-05 12:26:41.882  Status: User: Admin initiated a switch command (75/OTGW Reset/Off)
...
2018-10-05 12:27:38.762  (GW OpenTherm) Temp (Max.  Vloerverwarming)
2018-10-05 12:27:38.766  (GW OpenTherm) General/Percentage (Maximum Relative Modulation Level)

sincze
Starting Member
Starting Member
 
Posts: 38
Joined: June 2014
Location: Breda

Previous

Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: Bororo and 1 guest