Error 03 with Remeha Calenta in gateway mode

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

Re: Opentherm Gateway

Postby macpro » Mon Aug 08, 2016 4:38 pm

hvxl wrote:DP=00

Bedankt!
User avatar
macpro
Starting Member
Starting Member
 
Posts: 11
Joined: July 2016
Location: Third byte on the right

Re: Error 03 with Remeha Calenta in gateway mode

Postby macpro » Mon Aug 08, 2016 4:45 pm

You've concluded that the boiler is faulty. If I leave the OTGW out of the setup, everything works fine and the Calenta and iSense have no problem talking to each other.
Is it wise to involve the maintenance firm (Feenstra) so they could make some changes to the boiler?

Or is it better to wait until you have time to compose My Special Firmware (tm) ?
Big thanks in advance if your willing to to that.
User avatar
macpro
Starting Member
Starting Member
 
Posts: 11
Joined: July 2016
Location: Third byte on the right

Re: Error 03 with Remeha Calenta in gateway mode

Postby hvxl » Wed Aug 10, 2016 5:08 pm

Maybe faulty is a bit too strong. The boiler doesn't fully adhere to the specifications. It looks like Remeha obviated that via some code in the iSense.

This special firmware inverts the data received from the boiler. Unless your boiler now suddenly starts sending uninverted data, it should work in your specific situation. On my system I only get error 03 responses. So that's good. I couldn't easily test it much further. I'll leave that to you.
Schelte
hvxl
Senior Member
Senior Member
 
Posts: 1190
Joined: June 2010

Re: Error 03 with Remeha Calenta in gateway mode

Postby macpro » Wed Aug 10, 2016 6:53 pm

OT Monitor was running in Monitor mode.
Installed the Special Firmware.
Logging started to show Errors 03 immediately?!
Changed to Gateway mode and they stopped.

So your inversion means that from now on Monitor mode no longer will work?

Turned the dial on the iSense to set the room setpoint.
The backlight remained off, but after a short while OT Monitor saw the new temperature I set.

Pushed the “back to program” button and this time the backlight worked.
And OT Monitor showed the standard temperature after a short time.

Turned the dial again and backlight went blue.
This time I set the setpoint to above the room temperature, thus forcing the boiler to go on.
Both the iSense and OT Monitor show the same info and it works.

For now it looks like the OTGW is capable of talking to the boiler and thermostat.

Next step will be to learn how I should “talk” to the OTGW so I can control the temperature.

Thank you very much for your help and time.
Greatly appreciated.
User avatar
macpro
Starting Member
Starting Member
 
Posts: 11
Joined: July 2016
Location: Third byte on the right

Re: Error 03 with Remeha Calenta in gateway mode

Postby hvxl » Wed Aug 10, 2016 8:19 pm

Things are still very curious. At the end of a firmware upgrade the gateway resets and it always starts in gateway mode. So the errors 03 suggest that the boiler did not switch to medium power this time. Setting gateway mode while it is already in gateway mode, is a noop. So how this can stop the errors is another puzzling thing.

The inversion is only done in gateway mode. Monitor mode still works exactly the same as before. But when switching from gateway mode, the iSense will probably be in low power mode, while the boiler is in medium power mode. It may take a while for the thermostat to determine and correct this mismatch. In monitor mode the gateway will report error 03 when medium/high power mode is active.

After loading firmware, the thermostat and gateway may not be in sync about smart power support. If necessary, you can remove the power from the gateway to line them up.
Schelte
hvxl
Senior Member
Senior Member
 
Posts: 1190
Joined: June 2010

Previous

Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest