otmonitor linked to old ssl/crypto libraries

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

otmonitor linked to old ssl/crypto libraries

Postby algol » Mon Jan 01, 2018 3:11 pm

Hi, happy new new year to all of you!

I control my Hoval boiler using an OTGW and would like to activate the alerts when by boiler goes into fault through SMS messaging. I'm connecting to the OTGW with a RaspberryPi 2 running Raspbian Stretch.

it appears that otmonitor 4.3 is calling the libssl1.0.0 and libcrypto1.0.0 and gives an error when triggering an alert. These libraries have been replaced by 1.0.2.

I have tried creating linux soft links from 1.0.0 to 1.0.2, but that also fails as the OpenSSL version also differs. I have also tried adding the older 1.0.0 libraries, but that also fails with a 302 error.

UPDATE: adding the old libraries in /usr/bin actually allows to send e-mails again. Only the SMS seems to fail with an error 302 and this seems to be linked to the provider I'm using VoipCheap. I rapidly went through t^source and didn't see anything wrong.

Does OTMonitor have a log (aside from the OTGW log)?


Anyone found a solution to this? Is there a more recent tclkit for arm that uses updated libraries?

Thanks for any help!

Arnaud
algol
Starting Member
Starting Member
 
Posts: 6
Joined: July 2013

Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest