Page 1 of 1

[SOLVED] Control setpoint (CS) maximised to 40C by boiler

PostPosted: Thu Jan 10, 2019 1:35 am
by Wavemaker
I have an Intergas type HRE 28/24 kettle with the opentherm gateway connected through ethernet with an nodemcu. I was expirimenting with passing a direct control setpoint. I note that my kettle does not go higher than 40C. I can specify a higher value on the serial connection or in otmonitor, but it is not honored. I see that the value changes to my requested value in otmonitor. But the kettle shows at maximum 40C.

Obviously I have made sure that the maximum setpoint of the kettle is higher (75C). And when operating normally (with a Honeywell thermostat) the kettle can actually go much higher than 40C.

Is anybody familiar with this situation? Is there anything that can be done?

EDIT: When fiddling further with the kettle, I find that the device has TWO menus to set the maximum water temperature. Apparently one of them was used with normal operation (Honeywell) thermostat and the other when using the OTGW to send a control setpoint. The latter one was set to 40C. I have no idea why the two methods to send setpoints are treated differently by this kettle, but it works now.

Re: [SOLVED] Control setpoint (CS) maximised to 40C by boiler

PostPosted: Tue Jan 15, 2019 10:05 pm
by hvxl
This sounds very strange. The Honeywell thermostat would use the same OT messages to control the boiler as the OTGW does. It would be unusual if the boiler uses different configuration settings for the two devices.

Re: [SOLVED] Control setpoint (CS) maximised to 40C by boiler

PostPosted: Wed Feb 13, 2019 8:31 am
by mwtheplumber
Which parameters are you changing on the Intergas?