Page 1 of 1

Honeywell Chronotherm Modulation

PostPosted: Mon May 27, 2019 10:01 pm
by YogiBear75NL
Hello all,

I have the OTGW and a Honeywell Chronotherm Modulation.
OpenTherm firmware OpenTherm Gateway 4.2.5
It's working fine in Home Assistant using an ESP32 with Ser2Net.
I can set the Control Point and read all variables necessary.

But...the time on the Honeywell Chronotherm Modylation is not correct anymore.
It's slowly getting ahead of time. If I don't enable/have the OTGW in between, the time is correct. Well maybe a 5 seconds difference in a week.
But now during a day it's 1 hour ahead of time.

Is this a known issue? What can I do to prevent this as I want to use the Program on the Thermostat.

Thanks

Re: Honeywell Chronotherm Modulation

PostPosted: Fri Jun 14, 2019 10:15 am
by hvxl
This is not an issue known to me. When I was using the Honeywell Chronotherm Modulation myself, the time was accurate to the second. But I have to admit that was because I kept the OTGW informed of the correct time by sending it SC commands every minute. It would then relay that information to the thermostat.

So it is possible for the OTGW to influence the clock of this thermostat type. But it shouldn't do that unless it is told to do so via SC commands. Otherwise it should behave no different than a boiler would.

1 hour in a day translates to 2.5 minutes per hour. Can you collect a log from otmonitor for one hour that shows this problem? Then I will have a look to see if I can spot what may be causing it.