LED connection on OTG

This Forum is about the Opentherm gateway (OTG) from Schelte

Moderator: hvxl

LED connection on OTG

Postby raymonvdm » Wed May 01, 2013 10:36 pm

I would like to know how to connect the leds on the OpenThermGateway PCB, can somebody tell me which resistors i need ? I did not find the answer yet
Running HS3PRO on PC with Z-Wave / OpenTherm / Plugwise / RFXcom / MQTT / XAP400 / Logitech Media Server and Squeezelite on PI`s
raymonvdm
Senior Member
Senior Member
 
Posts: 1153
Joined: December 2011

Re: LED connection on OTG

Postby yjb » Thu May 02, 2013 7:09 am

This is being documented on the following page:

tclcode.com/opentherm/firmware.html#ind ... indicators

Indicators
Since the PIC had some unused I/O pins, I decided to use a couple of those to allow LEDs to be connected for indicating certain situations. The LEDs are supposed to be connected to VCC through a resistor of an appropriate value (something between 180 Ohm and 1 kOhm).


Cheers,

Ysbrand
yjb
Member
Member
 
Posts: 197
Joined: April 2009
Location: Venhuizen, Netherlands

Re: LED connection on OTG

Postby hvxl » Fri May 03, 2013 11:07 pm

It depends on the type (and even colour) of LEDs you plan to connect and how bright you want them to be. I'm using some plain old 5mm round LEDs myself and am quite happy with these values: Red LED: 680 Ohm, Green LED: 470 Ohm, Yellow LED: 330 Ohm.
Schelte
hvxl
Senior Member
Senior Member
 
Posts: 1264
Joined: June 2010


Return to Opentherm Gateway Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron