Startup issues on OpenHAB

Forum about OpenHAB open Source Home Automation.

Moderator: raymonvdm

Startup issues on OpenHAB

Postby raymonvdm » Fri Jan 31, 2014 10:20 pm

I`m trying to setup OpenHAB but it is not starting up correctly

Code: Select all
22:16:26.779 INFO  o.o.c.internal.CoreActivator[:92]- openHAB runtime has been started (v1.3.1).
22:16:32.434 INFO  o.o.i.t.mqtt.MqttService[:122]- MQTT Service initialization completed.
22:16:32.443 INFO  o.o.i.t.m.i.MqttBrokerConnection[:126]- Starting MQTT broker connection 'homeseer'
22:16:37.776 INFO  o.o.i.s.i.DiscoveryServiceImpl[:92]- mDNS service has been started
22:16:40.454 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'raqxs.sitemap'
22:16:41.606 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'demo.sitemap'
22:16:42.363 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'demo.script'
22:16:43.168 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'rrd4j.persist'
22:16:43.316 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'exec.persist'
22:16:43.351 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'logging.persist'
22:16:43.400 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'db4o.persist'
22:16:43.601 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'raqxs.items'
22:16:45.045 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'demo.items'
22:16:46.306 INFO  o.o.i.r.i.RESTApplication[:158]- Started REST API at /rest
22:16:51.549 INFO  o.o.u.w.i.s.WebAppServlet[:99]- Started Classic UI at /openhab.app
22:16:55.553 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'demo.rules'
22:17:00.436 ERROR o.o.i.multimedia.actions.Audio[:231]- No TTS service available - tried to say: Welcome at openHab!
22:17:05.611 WARN  o.o.c.p.e.PersistenceExtensions[:417]- There is no queryable persistence service registered with the name 'rrd4j'
22:17:05.632 ERROR o.o.m.r.i.engine.RuleEngine[:287]- Error during the execution of startup rule 'Update max and min temperatures': cannot invoke metho                                d public abstract org.openhab.core.types.State org.openhab.core.persistence.HistoricItem.getState() on null
22:17:05.642 WARN  o.o.b.a.i.AsteriskGenericBindingProvider[:98]- bindingConfig is NULL (item=Incoming_Call (Type=SwitchItem, State=Uninitialized)) ->                                 processing bindingConfig aborted!
22:17:05.662 WARN  o.o.b.a.i.AsteriskGenericBindingProvider[:98]- bindingConfig is NULL (item=Active_Call (Type=CallItem, State=Uninitialized)) -> proc                                essing bindingConfig aborted!
22:17:05.675 WARN  o.o.b.a.i.AsteriskGenericBindingProvider[:98]- bindingConfig is NULL (item=Active_Call (Type=CallItem, State=Uninitialized)) -> proc                                essing bindingConfig aborted!
22:17:05.658 INFO  o.o.m.c.i.ModelRepositoryImpl[:99]- Loading model 'raqxs.rules'
22:17:05.681 WARN  o.o.m.c.i.ModelRepositoryImpl[:78]- Configuration model 'raqxs.rules' is either empty or cannot be parsed correctly!
22:17:06.410 ERROR o.e.x.r.i.DefaultResourceDescription[:75]- raqxs.rules (No such file or directory)
java.io.FileNotFoundException: raqxs.rules (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:140)
        at org.eclipse.emf.ecore.resource.impl.FileURIHandlerImpl.createInputStream(FileURIHandlerImpl.java:99)
        at org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:354)
        at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1256)
        at org.eclipse.xtext.resource.impl.DefaultResourceDescription.computeExportedObjects(DefaultResourceDescription.java:73)
22:17:07.585 INFO  o.o.c.s.AbstractActiveService[:189]- NTP Refresh Service has been started
22:17:12.205 INFO  o.o.c.s.AbstractActiveService[:189]- HTTP Refresh Service has been started




The issue seem to be related to the asterisk binding, but i`m not sure what i`m missing
Code: Select all
22:23:49.502 WARN  o.o.b.a.i.AsteriskGenericBindingProvider[:98]- bindingConfig is NULL (item=Incoming_Call (Type=SwitchItem, State=Uninitialized)) -> processing bindingConfig aborted!
22:23:49.503 WARN  o.o.b.a.i.AsteriskGenericBindingProvider[:98]- bindingConfig is NULL (item=Active_Call (Type=CallItem, State=Uninitialized)) -> processing bindingConfig aborted!
22:23:49.504 WARN  o.o.b.a.i.AsteriskGenericBindingProvider[:98]- bindingConfig is NULL (item=Active_Call (Type=CallItem, State=Uninitialized)) -> processing bindingConfig aborted!



I`m trying the following documentation, but i`m not sure what to do next
https://github.com/openhab/openhab/wiki ... sk-Binding



Update: I`ve made some progress

Code: Select all
vim /home/beheer/openhab/configurations/items/raqxs.sitemap

Group item=Asterisk icon="Asterisk"


Code: Select all
vim /home/beheer/openhab/configurations/items/raqxs.items

Group Asterisk          "Asterisk"              <Asterisk>              (Asterisk)


Code: Select all
/* Asterisk */

asterisk=active

Switch Incoming_Call    "Ringing"                       (Asterisk)    { asterisk=active }
Number Active_Call        "Connected [to %1$s from %2$s]" (Asterisk)    { asterisk=active }
Number Active_Call        "Connected to [%s]"             (Asterisk)    { asterisk=active }



Code: Select all
vim openhab/configurations/rules/raqxs.rules

rule "active call"
      when
      Item Active_Call received update
      then
      println(">>>>>>>" + Active_Call.state + "<")      
      end

Running HS3PRO on PC with Z-Wave / OpenTherm / Plugwise / RFXcom / MQTT / XAP400 / Logitech Media Server and Squeezelite on PI`s
raymonvdm
Senior Member
Senior Member
 
Posts: 1128
Joined: December 2011

Re: Startup issues on OpenHAB

Postby raymonvdm » Sun Jan 04, 2015 10:57 pm

Another year, Another Shot, Same issue :cry:
Running HS3PRO on PC with Z-Wave / OpenTherm / Plugwise / RFXcom / MQTT / XAP400 / Logitech Media Server and Squeezelite on PI`s
raymonvdm
Senior Member
Senior Member
 
Posts: 1128
Joined: December 2011


Return to OpenHAB Forum

Who is online

Users browsing this forum: No registered users and 1 guest