Toon app: ToonStore

Forum about forum-provided applications on Toon

Moderator: marcelr

Re: Toon app: ToonStore

Postby ericT » Fri Jan 26, 2018 4:22 pm

Hi all,

I've tried to install ToonStore on my 4.11.6, but get the following error:

Code: Select all
eneco-xxx-xxxxxx:~# opkg install toonstore_1.1.1-r0_qb2.ipk
Installing toonstore (1.1.1-r0) to root...
Executing pre-install script for toonstore-1.1.1
grep: /usr/lib/opkg/info/base-qb2-ene.control: No such file or directory
sh: bad number
Hmmm ... no project file found. Shouldn't happen.


The file base-qb2-ene.control doesn't exist, but there is a base-qb2-uni.control...

Eric
ericT
Starting Member
Starting Member
 
Posts: 9
Joined: June 2017

Re: Toon app: ToonStore

Postby marcelr » Mon Jan 29, 2018 7:58 pm

This issue has been resolved.

If you have tried to install toonstore-1.1.1 or earlier on FW 4.11.6, please make a copy of /etc/hosts.toonstore_backup before installing a newer version.

Oh, by the way, toonstore-1.1.2 is now available from the toonstore :-)
marcelr
Advanced Member
Advanced Member
 
Posts: 925
Joined: May 2012
Location: Ehv

Re: Toon app: ToonStore

Postby Toonz » Tue Jan 30, 2018 9:45 pm

Hi all,

ToonStore 1.1.3 is available now.
Changelog:
- when there is a ToonStore update available, the button to remove ToonStore was accidentally enabled.
Button will not shop up anymore to prevent unwanted removal of ToonStore.

Kind regardz,

Toonz
Toonz
Advanced Member
Advanced Member
 
Posts: 718
Joined: December 2016

Re: Toon app: ToonStore

Postby ericT » Thu Feb 01, 2018 7:45 pm

@Marcel Thanks! Install succeeded.
ericT
Starting Member
Starting Member
 
Posts: 9
Joined: June 2017

Re: Toon app: ToonStore

Postby TheHogNL » Fri Feb 16, 2018 1:40 pm

Could you please update the easyEnergy app on the store? 1.2.3 is already available in the topic about easyenergy (first post) but the store still provides 1.2.0 which contains a few errors
TheHogNL
Member
Member
 
Posts: 446
Joined: August 2017

Re: Toon app: ToonStore

Postby Toonz » Fri Feb 16, 2018 1:58 pm

TheHogNL wrote:Could you please update the easyEnergy app on the store? 1.2.3 is already available in the topic about easyenergy (first post) but the store still provides 1.2.0 which contains a few errors

Sure, can do over the weekend. With future updates drop me a PM when ready......
Toonz
Advanced Member
Advanced Member
 
Posts: 718
Joined: December 2016

Re: Toon app: ToonStore

Postby Toonz » Sun Feb 18, 2018 8:57 pm

EasyEnergy version 1.2.3 is available via ToonStore ......
Toonz
Advanced Member
Advanced Member
 
Posts: 718
Joined: December 2016

Re: Toon app: ToonStore

Postby TheHogNL » Sat Feb 24, 2018 4:22 pm

Just upgraded Toon to 4.11.6. Toon store isn't showing the firmware in the bottom screen. Because the Toon changed from ene to uni, the firmware check is now pointing to the wrong file.
TheHogNL
Member
Member
 
Posts: 446
Joined: August 2017

Re: Toon app: ToonStore

Postby marcelr » Sat Feb 24, 2018 4:59 pm

Has been resolved in toonstore-1.1.2.
marcelr
Advanced Member
Advanced Member
 
Posts: 925
Joined: May 2012
Location: Ehv

Re: Toon app: ToonStore

Postby TheHogNL » Sat Feb 24, 2018 5:42 pm

Hmm I see that in the changelog indeed however, I'm running 1.1.3 and it didn't show the firmware version. Only after I changed the code to look at the uni file instead of ene.
TheHogNL
Member
Member
 
Posts: 446
Joined: August 2017

Re: Toon app: ToonStore

Postby marcelr » Sat Feb 24, 2018 6:07 pm

Could be. I changed the installer to reflect the right FW version file (base-qb2-uni<whatever>). Not sure if that also landed in the qml code. Will take a look.
marcelr
Advanced Member
Advanced Member
 
Posts: 925
Joined: May 2012
Location: Ehv

Re: Toon app: ToonStore

Postby Toonz » Sat Feb 24, 2018 11:05 pm

The displayed version number in ToonStore is taken from the file /usr/lib/opkg/info/base-qb2-ene.control.
This should be taken from the file /usr/lib/opkg/info/base-qb2-uni.control for the newest firmwares.

Will change this in next version of ToonStore (next weekend or so)
Toonz
Advanced Member
Advanced Member
 
Posts: 718
Joined: December 2016

Re: Toon app: ToonStore

Postby marcelr » Sat Feb 24, 2018 11:12 pm

Never mind, Toonz, it's done already, but thanks anyway. Will test tomorrow. (It's too cold in my attic, right now).
marcelr
Advanced Member
Advanced Member
 
Posts: 925
Joined: May 2012
Location: Ehv

Re: Toon app: ToonStore

Postby marcelr » Sun Feb 25, 2018 12:51 pm

Toonstore updated to 1.1.4, available from the Toonstore. FW version display fixed.
marcelr
Advanced Member
Advanced Member
 
Posts: 925
Joined: May 2012
Location: Ehv

Re: Toon app: ToonStore

Postby odelay99 » Sat Mar 10, 2018 1:47 pm

Hi,
I updated my Toon with the Toon firmware - update script from TheHogNL from 4.4.21 to 4.10.6 and again to the latest 4.13.7 which all went great (thanks for that TheHogNL).
Then I realized that my apps from the toonstore where gone. So I deleted the folders from /qmf/qml/apps including toonstore folder itself. I reinstalled the latest Toonstore but still no apps, I uninstalled with "opkg remove toonstore" and reinstalled again but without any luck.
So now I got the Toonstore installed but when I install an app it shows as not installed after the reboot..
I have attached the log.
Can someone tell me what I'm do wrong?
Attachments
_opkg.qb2-uni-9.9.99.script.sh.zip
log file
(1.19 KiB) Downloaded 28 times
odelay99
Starting Member
Starting Member
 
Posts: 20
Joined: May 2017

PreviousNext

Return to Toon Apps

Who is online

Users browsing this forum: No registered users and 0 guests

cron