Toon app: ToonStore

Forum about forum-provided applications on Toon

Moderators: marcelr, TerrorSource, Toonz, TheHogNL

Re: Toon app: ToonStore

Postby SDeath » Fri Feb 22, 2019 9:48 pm

I can't update any of the apps using the Toonstore?
I also can't uninstall the apps using the Toonstore?
It just returns to the home screen after pressing "Toon Bijwerken" and does nothing.

Manually removing the app, reboot GUI and try to install via the Toonstore also doesn't work?
I tried rebooting, but somehow it doesn't want to (un)install anything anymore using the Toonstore.
What can I do to fix this?
Toon1 running firmware 5.2.11 (rooted)
SDeath
Starting Member
Starting Member
 
Posts: 49
Joined: January 2019

Re: Toon app: ToonStore

Postby Toonz » Fri Feb 22, 2019 10:01 pm

most likely you need to fix the hcb_web settings in /qmf/etc/qmf_release.xml.
Especially the tags defaultEntry and enforceWhitelist>.

Code: Select all
   <hcb_web>
      <defaultEntry>/qmf/www/</defaultEntry>
      <enforceWhitelist>0</enforceWhitelist>
      <whitelist>
         <item>hdrv_zwave</item>
         <item>happ_zware</item>
         <item>rsrc</item>
      </whitelist>
   </hcb_web>
member of the Toon Software Collective
User avatar
Toonz
Forum Moderator
Forum Moderator
 
Posts: 1453
Joined: December 2016

Re: Toon app: ToonStore

Postby SDeath » Fri Feb 22, 2019 10:08 pm

You mean the extra spaces in front of those lines?
Toon1 running firmware 5.2.11 (rooted)
SDeath
Starting Member
Starting Member
 
Posts: 49
Joined: January 2019

Re: Toon app: ToonStore

Postby SDeath » Fri Feb 22, 2019 10:18 pm

Changed it to exactly what you had and did a full reboot still doesn't update the apps.
Toon1 running firmware 5.2.11 (rooted)
SDeath
Starting Member
Starting Member
 
Posts: 49
Joined: January 2019

Re: Toon app: ToonStore

Postby Toonz » Fri Feb 22, 2019 10:30 pm

Ok, second usual suspect : /etc/hosts
Can you check whether that looks normal (no double entries)
member of the Toon Software Collective
User avatar
Toonz
Forum Moderator
Forum Moderator
 
Posts: 1453
Joined: December 2016

Re: Toon app: ToonStore

Postby SDeath » Fri Feb 22, 2019 10:36 pm

it is empty
Toon1 running firmware 5.2.11 (rooted)
SDeath
Starting Member
Starting Member
 
Posts: 49
Joined: January 2019

Re: Toon app: ToonStore

Postby SDeath » Fri Feb 22, 2019 10:45 pm

So that was the problem, I put the content from /etc/hosts.toonstore_backup into the /etc/hosts file and I could update the apps.
Thanks for pointing me in the right direction, but how could this happen?
Toon1 running firmware 5.2.11 (rooted)
SDeath
Starting Member
Starting Member
 
Posts: 49
Joined: January 2019

Re: Toon app: ToonStore

Postby MP51 » Sat Feb 23, 2019 8:41 pm

Running firmware version 4.13.6
After i update toonstore from 2.0.2 to 2.1.2 i have the following issue,
When i try to update app's i get the message firmware update available and the message and download icon are shown
But the app that i select in the toonstore isn't updating.

What could be the reason ?
MP51
Starting Member
Starting Member
 
Posts: 6
Joined: February 2019

Re: Toon app: ToonStore

Postby MP51 » Mon Feb 25, 2019 1:15 pm

issue solved by updating toon to version 5.0.4 :D
MP51
Starting Member
Starting Member
 
Posts: 6
Joined: February 2019

Re: Toon app: ToonStore

Postby WickedMaster » Mon Feb 25, 2019 11:18 pm

opkg install http://files.domoticaforum.eu/uploads/T ... r0_qb2.ipk
Downloading http://files.domoticaforum.eu/uploads/T ... r0_qb2.ipk.
Installing toonstore (2.1.2-r0) to root...
Executing pre-install script for toonstore-2.1.2
Hmmm ... no project file found. Shouldn't happen.

Known error?

Edit: Fixed it by creating qmf_release.xml manually. I think I somehow deleted it accidentally.
User avatar
WickedMaster
Member
Member
 
Posts: 75
Joined: November 2018

Re: Toon app: ToonStore

Postby Toonz » Tue Feb 26, 2019 12:05 am

As we stated in the install script :this should never happen.... :). Glad you fixed it. Would like to hear from others if they experience the same
member of the Toon Software Collective
User avatar
Toonz
Forum Moderator
Forum Moderator
 
Posts: 1453
Joined: December 2016

Re: Toon app: ToonStore

Postby TerrorSource » Tue Feb 26, 2019 9:33 am

WickedMaster wrote:
opkg install http://files.domoticaforum.eu/uploads/T ... r0_qb2.ipk
Downloading http://files.domoticaforum.eu/uploads/T ... r0_qb2.ipk.
Installing toonstore (2.1.2-r0) to root...
Executing pre-install script for toonstore-2.1.2
Hmmm ... no project file found. Shouldn't happen.

Known error?

Edit: Fixed it by creating qmf_release.xml manually. I think I somehow deleted it accidentally.


On what firmware did you receive this error?
I had the same error on a 5.0.4 (officially updated to 5.0.4) Toon, which was never rooted before.
TerrorSource
Member
Member
 
Posts: 398
Joined: May 2017

Re: Toon app: ToonStore

Postby WickedMaster » Tue Feb 26, 2019 9:58 am

This was also on a 5.0.4, updated manually. But this one was rooted already.
User avatar
WickedMaster
Member
Member
 
Posts: 75
Joined: November 2018

Re: Toon app: ToonStore

Postby richardklasens » Thu Feb 28, 2019 9:53 pm

MP51 wrote:Running firmware version 4.13.6
After i update toonstore from 2.0.2 to 2.1.2 i have the following issue,
When i try to update app's i get the message firmware update available and the message and download icon are shown
But the app that i select in the toonstore isn't updating.

What could be the reason ?


Had almost the same, my /etc/hosts file had 2 lines with 127.0.0.1 , one for local and one for feed.hae.int
richardklasens
Starting Member
Starting Member
 
Posts: 15
Joined: February 2019

Re: Toon app: ToonStore

Postby richardklasens » Thu Feb 28, 2019 10:07 pm

and also no luck... My toonstore won't install or remove apps.
SW 2.12
Firmware 5.04

I've checked hosts and the lines in qml_release. nothing strange... i guess.

Help :)
richardklasens
Starting Member
Starting Member
 
Posts: 15
Joined: February 2019

PreviousNext

Return to Toon Apps

Who is online

Users browsing this forum: No registered users and 1 guest

cron