ZonOpToon alternative

Forum about Toon hardware, both versions 1 and 2 of Toon

Moderators: marcelr, TheHogNL, Toonz

vso
Member
Member
Posts: 63
Joined: Wed Mar 27, 2019 11:27 pm

Re: ZonOpToon alternative

Post by vso »

wierd .. as a led I used a electric flyswater ... it worked .. because of no solar "generation" the pulse is off .. (duh)
the "old" pulse meter ..

but it worked instantly .. pfff wierd

anyway .. i mounted it on the powermeter .. (tested before just to double check ..) lets see what happens tomorrow ..

But I think the error is in the meteradapter .. joint not propperly solderd oid .. flex in the board .. so I am unsure if the powermeter is S0 is broken from this or previous one ..

Now i just want a day of "data" .. if this works I will test again ..
TheHogNL
Forum Moderator
Forum Moderator
Posts: 2112
Joined: Sun Aug 20, 2017 8:53 pm

Re: ZonOpToon alternative

Post by TheHogNL »

vso wrote: the cable has no interruptions .. (1:1 of left to right ..) and I am guessing the light sensor is smart enough to "short" .. 2-4 and 1 itself .. (simulair as the drawing only this logic will be in the "sensor" ..
What do you mean short itself? 2-4 and 1 must be always connected to each other. There is NO logic in the sensor!
Only 3 (the tip of the 3.5mm jack) will be 'shorted' to the rest using the button, the s0 or the manual short trick.

And what your are doing with a flysatter and what is working now, I am really puzzeled. Maybe switch to dutch because I have a hard time understanding your english.
Member of the Toon Software Collective
vso
Member
Member
Posts: 63
Joined: Wed Mar 27, 2019 11:27 pm

Re: ZonOpToon alternative

Post by vso »

TheHogNL wrote:
vso wrote: the cable has no interruptions .. (1:1 of left to right ..) and I am guessing the light sensor is smart enough to "short" .. 2-4 and 1 itself .. (simulair as the drawing only this logic will be in the "sensor" ..
What do you mean short itself? 2-4 and 1 must be always connected to each other. There is NO logic in the sensor!
Only 3 (the tip of the 3.5mm jack) will be 'shorted' to the rest using the button, the s0 or the manual short trick.

And what your are doing with a flysatter and what is working now, I am really puzzeled. Maybe switch to dutch because I have a hard time understanding your english.
the electric flyswatter has a led when I push the button bugs get zapped and it has and LED lights up ..
so lab conditions you explained IF the meteradapter allows it will work ..

the issue is there is no constancy from the meteradapter .. sometimes it allows the test .. sometimes it will not ..

dutch:
er is geen onbegrip van jou uitleg en ALS ik de meter adapter test met de 2 kabeltjes (knopje of kortsluiten) of met een LED zie ik op de meteradapter de Led knipperen ..
maar de meteradapter is niet consistent .. wanneer ik het in de meterkast plug hoe ik hem er ook erin plug .. de LED van de pulse /s0 verbinding blijft constant groen ..

gisterenavond .. even bij de computer "getest" met rode LED .. yup .. werkt .. terug de meterkast in .. getest (met vliegenmepper)... yup het werkt .. (natuurlijk geen zon) .. dus dat ding netjes over de puls LED gepositioneerd

Ik kom beneden en de installatie genereert zonneenergie ..(kwh meter knippert er vrolijk op los)
maar #%I&$#)(%*_#@%*_ @*& geen enkele puls word geregisteerd .. schiet mij maar lek .. hoe dit komt ..

kijk het kan best aan de kwh meter liggen dat s0 niet werkt oid .. maar een pulserend LED op de meter is wat het is ..
De puls lezer van de meter adapter is niet defect .. sterker nog pak ik de vliegenmepper (voor de LED) dan met paar keer drukken of sensor eroverheen bewegen .. "pats" geactiveerd .. groene constante LED weg ..
plaats ik hem echter terug over de KWH meter .. die vrolijk knippert .. "dood" geen enkele reactie v.d meteradapter/ledsensor .. it as if no LED is registerd ..

back to EN:
the "old" one disassembeld

Image

fyi of course the "housing" plasticleft out

I will replace this unit back into the system .. only remove the plastic window .. see if that helps .. if not I will replace led ?
TheHogNL
Forum Moderator
Forum Moderator
Posts: 2112
Joined: Sun Aug 20, 2017 8:53 pm

Re: ZonOpToon alternative

Post by TheHogNL »

Het kan zijn dat de led gewoon te zwak is om gedetecteerd te worden of de led pulse te kort duurt om voor de meteradapter op te merken als een puls.
Gezien het met S0 ook niet werkt denk ik het laatste (te kort dus).
Member of the Toon Software Collective
Ron_nl
Member
Member
Posts: 77
Joined: Tue Mar 26, 2019 3:20 pm
Location: Friesland

Re: ZonOpToon alternative

Post by Ron_nl »

Heb je nog een andere optische opnemer die je kunt gebruiken, wellicht is die gevoeliger o.i.d

Of die LED produceert niet genoeg licht door het kleine gaatje van de behuizing, mss kun je het gaatje iets opboren.
Als ik op de foto kijk zie ik dat de LED vanaf de zijkant licht geeft door het gaatje van de behuizing, kan net iets minder licht zijn als dat hij vanaf de "kop" geeft.

Zomaar even een paar gedachtes..

Ron.
vso
Member
Member
Posts: 63
Joined: Wed Mar 27, 2019 11:27 pm

Re: ZonOpToon alternative

Post by vso »

TheHogNL wrote:Het kan zijn dat de led gewoon te zwak is om gedetecteerd te worden of de led pulse te kort duurt om voor de meteradapter op te merken als een puls.
Gezien het met S0 ook niet werkt denk ik het laatste (te kort dus).
true
yes that is my thoughts to, (led being to soft/weak) .. so I tried to use a drill however ..window material is to thick .. so i am going to replace it with the old unit (having removed the "glass" ) .. next option is to replace the LED (soldering)

Ron_nl wrote:Heb je nog een andere optische opnemer die je kunt gebruiken, wellicht is die gevoeliger o.i.d

Of die LED produceert niet genoeg licht door het kleine gaatje van de behuizing, mss kun je het gaatje iets opboren.
Als ik op de foto kijk zie ik dat de LED vanaf de zijkant licht geeft door het gaatje van de behuizing, kan net iets minder licht zijn als dat hij vanaf de "kop" geeft.

Zomaar even een paar gedachtes..

Ron.
i could do some mods but .. lets try minimal modification first .. thx for assistance ! i will keep these options open
vso
Member
Member
Posts: 63
Joined: Wed Mar 27, 2019 11:27 pm

Re: ZonOpToon alternative

Post by vso »

hi so an update ..

I de-solderd the LED on the board, and replaced with wires.. *black + red
also attached wires directly to the S0 screw terminals soldering points (green + orange)
also on the removed led solderd 2 cables since leds only work when + and - are connected propperly i didn't bother with kathode/anode.
- additional LED (straight from package) unknown spec's unfortunatly

Ps i use a 5 euro USB soldering iron .. and salvaged thin wire ..

This allowed me to test better ..
my conclusions (TLDR):
- supplied/solderd LED is weak but could work
- S0 does work ( I might have wrecked it ? )



TheHogNL wrote:Het kan zijn dat de led gewoon te zwak is om gedetecteerd te worden of de led pulse te kort duurt om voor de meteradapter op te merken als een puls.
Gezien het met S0 ook niet werkt denk ik het laatste (te kort dus).
- yes LED is weak even directly pointed to the "sensor" .. but when aligned right it does work
- swapping it with a better led is "recommended" I did and

When testing the S0 it didn't register on the multimeter (continuity setting did not beep..) so yes its "short" ..
however when connected now to the microjack / meteradapter it does work (same pulse as the LED) so the screw terminal(s) are junk ??
Ron_nl wrote:Heb je nog een andere optische opnemer die je kunt gebruiken, wellicht is die gevoeliger o.i.d

Of die LED produceert niet genoeg licht door het kleine gaatje van de behuizing, mss kun je het gaatje iets opboren.
Als ik op de foto kijk zie ik dat de LED vanaf de zijkant licht geeft door het gaatje van de behuizing, kan net iets minder licht zijn als dat hij vanaf de "kop" geeft.

Zomaar even een paar gedachtes..

Ron.
Yes you are right (led is sideways) but even "directly" it has "issues" .. so getting a "new" one and using the legs to get it to face directly trough the hole .. would be best ..



So this ordeal (many thanks again to TheHogNL) ..
The Power meter does work .. if you need/want to disasemple .. if you are carefull its easy to do
- all you need is a thin peace of metal .. (2 is better) and start left and right on .. to remove the DIN -Rail connector in the back lift a bit .. then do the same at the other end ..
now you can use the (large) screw terminals to push the board out ..
- press out the "window" ..
To desolder LED --> use a kitchen knife to apply "down-ward-pressure) between board and LED .. apply a little (new) solder to the contacts .. and then alternate between both points until LED pops out..


Anyway to be honest .. 20,- "no fuss" and maybe short delivery ? .. vs 7 or 8 euro and longer delivery time .. you decide ..
oepi-loepi
Advanced Member
Advanced Member
Posts: 505
Joined: Sat Feb 09, 2019 7:18 pm

Re: ZonOpToon alternative

Post by oepi-loepi »

It will be possible to use the Zon op Toon without the use of hardware.

viewtopic.php?f=99&t=13043&p=96485#p96485
Tin82
Starting Member
Starting Member
Posts: 5
Joined: Fri Jan 29, 2021 2:01 am

Re: ZonOpToon alternative

Post by Tin82 »

I used this meter:
€ 8,08 25%OFF | Din Rail Eenfase Reset Nul Energie Meter Kwh Spanning Stroom Stroomverbruik Teller Wattmeter Elektriciteit 220V-230V Ac
https://a.aliexpress.com/_mtjpvZ3

Works perfect with Zon op Toon.
Pieterraxis
Starting Member
Starting Member
Posts: 17
Joined: Mon Jun 01, 2020 9:24 pm

Re: ZonOpToon alternative

Post by Pieterraxis »

TheHogNL wrote: Thu Feb 15, 2018 5:43 pm That one is a modbus model and not S0.. modbus is something completly different.
Is modbus NOT compatible?
Post Reply

Return to “Toon Hardware”