Upgrade failed. Missing files

Forum about the tweaking of the Eneco Toon.

Moderator: marcelr

Upgrade failed. Missing files

Postby karll64 » Sun Jul 01, 2018 5:02 pm

I upgraded my Toon with the updated_rooted.sh scripts. Half-way the upgrade my SSH connection went down.
The scripts died half way the rm -f commands. So I ended up with a half installed Toon.

Also an opkg update does not work anymore. Host feed.hae.orig is not found even when the tunnel is up.

Is there a way to restore the Toon with the original firmware and restart the updated_rooted.sh script again?

Greetz,
Karl
karll64
Starting Member
Starting Member
 
Posts: 4
Joined: July 2018

Re: Upgrade failed. Missing files

Postby marcelr » Sun Jul 01, 2018 5:23 pm

karll64 wrote:Host feed.hae.orig is not found even when the tunnel is up.


This host doesn't exist. Maybe a typo in your /etc/hosts file?
-> feed.hae.int
marcelr
Advanced Member
Advanced Member
 
Posts: 840
Joined: May 2012
Location: Ehv

Re: Upgrade failed. Missing files

Postby karll64 » Sun Jul 01, 2018 5:31 pm

Nope. I think there is something seriously wrong.
The MAC address of my wlan is 00:00:00:00:00:00. The ethernet MAC is ok.
The original Toon logo circle with T is presented on the display and stays on the display.

I looked on the serial console and no error messages are displayed.
karll64
Starting Member
Starting Member
 
Posts: 4
Joined: July 2018

Re: Upgrade failed. Missing files

Postby TheHogNL » Mon Jul 02, 2018 6:37 am

marcelr wrote:
karll64 wrote:Host feed.hae.orig is not found even when the tunnel is up.


This host doesn't exist. Maybe a typo in your /etc/hosts file?
-> feed.hae.int



feed.hae.int is the localhost (for toonstore). the update script replaces the original feed.hae.int to feed.hae.orig :wink:
TheHogNL
Member
Member
 
Posts: 298
Joined: August 2017

Re: Upgrade failed. Missing files

Postby TheHogNL » Mon Jul 02, 2018 6:40 am

karll64 wrote:Nope. I think there is something seriously wrong.
The MAC address of my wlan is 00:00:00:00:00:00. The ethernet MAC is ok.
The original Toon logo circle with T is presented on the display and stays on the display.

I looked on the serial console and no error messages are displayed.


First of all, this should not happen. The update script is only a wrapper on top of the script from eneco/quby which does the actual update. This update has reboot protection in it so it will restart a failed update if it detects a reboot.

But it happened to you so I'm curious how. Let me try to help you remotely. Send me a teamviewer session in PM. Or your mobile number in PM so we can whatsapp the teamviewer session.
TheHogNL
Member
Member
 
Posts: 298
Joined: August 2017

Re: Upgrade failed. Missing files

Postby TerrorSource » Mon Jul 02, 2018 7:00 am

Can you try to run the update script once more and force the latest version?
> update-rooted.sh -v 4.16.8

This will re-download all 4.16.8 files and install them just like a normal update.
TerrorSource
Member
Member
 
Posts: 108
Joined: May 2017

Re: Upgrade failed. Missing files

Postby karll64 » Fri Jul 06, 2018 9:41 pm

Ok I'am bit further. The MAC address of the WiFi card is still all zero's.
And also the display with tiles is not displayed.
The display lookes like the on attached to this post. It stucks on this display and after a whilte the display becomes black.
Attachments
IMG_7124.JPG
IMG_7124.JPG (35.85 KiB) Viewed 217 times
Last edited by karll64 on Fri Jul 06, 2018 10:42 pm, edited 1 time in total.
karll64
Starting Member
Starting Member
 
Posts: 4
Joined: July 2018

Re: Upgrade failed. Missing files

Postby marcelr » Fri Jul 06, 2018 9:56 pm

Can't see anything :? Please try again.
marcelr
Advanced Member
Advanced Member
 
Posts: 840
Joined: May 2012
Location: Ehv

Re: Upgrade failed. Missing files

Postby TerrorSource » Sat Jul 07, 2018 9:15 pm

marcelr wrote:Can't see anything :? Please try again.


I can see the attachment now, loading bar(4.16.8 style) is 60% full, 40% empty.
Looks like the GUI files are broken/missing.
TerrorSource
Member
Member
 
Posts: 108
Joined: May 2017

Re: Upgrade failed. Missing files

Postby TheHogNL » Sun Jul 08, 2018 6:46 am

I already sent you another post on which I offered my help using teamviewer. From tomorrow on I'm on vacation so your only chance is today ;-)
TheHogNL
Member
Member
 
Posts: 298
Joined: August 2017

Re: Upgrade failed. Missing files

Postby karll64 » Sun Jul 08, 2018 10:21 am

TheHogNL wrote:I already sent you another post on which I offered my help using teamviewer. From tomorrow on I'm on vacation so your only chance is today ;-)

I have sent you a e-mail with my contact details.
Gr
Karl
karll64
Starting Member
Starting Member
 
Posts: 4
Joined: July 2018


Return to Eneco Toon as Domotica controller

Who is online

Users browsing this forum: No registered users and 1 guest