Toon not booting after failed update

If your (rooted) Toon doesn't do what it's supposed to, post here. Dutch allowed / Posten in 't Nederlands toegestaan.

Moderator: marcelr

Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 6:38 pm

Hey.

I tried doing a software update, and the power fell out during the update.
I can access SSH, and the screen is stuck at the T logo.

I tried using the update script, but it cannot seem to connect to the vpn. The keys are in the vpn folder.

What can i do?

Thanks
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby TerrorSource » Mon Sep 03, 2018 7:27 pm

can you try the update script as followed:
sh update-rooted.sh -v 4.19.10

and tell us wat happens :)
TerrorSource
Member
Member
 
Posts: 154
Joined: May 2017

Re: Toon not booting after failed update

Postby marcelr » Mon Sep 03, 2018 7:30 pm

So it is booting.

You can test whether vpn is started by typing

Code: Select all
ps | grep vpn


If that gives no output (or nothing useful) you can start vpn manually by copying the command part of the openvpn line from /etc/inittab into the ssh console and run it.
marcelr
Advanced Member
Advanced Member
 
Posts: 909
Joined: May 2012
Location: Ehv

Re: Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 7:36 pm

Hey. With the forcing it is still waiting for VPN to be alive. See the screenshot.

Thank you :)
Attachments
F18B8768-260E-4BB2-AC4A-DBF04CABFC95.jpeg
F18B8768-260E-4BB2-AC4A-DBF04CABFC95.jpeg (125.34 KiB) Viewed 216 times
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 7:41 pm

As far as I can see it is running.
I see the line and the conf file defined there.

marcelr wrote:So it is booting.

You can test whether vpn is started by typing

Code: Select all
ps | grep vpn


If that gives no output (or nothing useful) you can start vpn manually by copying the command part of the openvpn line from /etc/inittab into the ssh console and run it.
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby TerrorSource » Mon Sep 03, 2018 7:42 pm

MadDemonoide wrote:Hey. With the forcing it is still waiting for VPN to be alive. See the screenshot.

Thank you :)


Just keep trying a few times. had that once before too.
Also, check the /etc/inittab if it's not empty.
TerrorSource
Member
Member
 
Posts: 154
Joined: May 2017

Re: Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 7:45 pm

I tried a few times now. Nothing changes.

The inittab is not empty. The openvpn item is there. Uncommented.

TerrorSource wrote:
MadDemonoide wrote:Hey. With the forcing it is still waiting for VPN to be alive. See the screenshot.

Thank you :)


Just keep trying a few times. had that once before too.
Also, check the /etc/inittab if it's not empty.
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby marcelr » Mon Sep 03, 2018 7:49 pm

In that case, you should be able to ping feed.hae.int, and get a response.
marcelr
Advanced Member
Advanced Member
 
Posts: 909
Joined: May 2012
Location: Ehv

Re: Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 7:51 pm

marcelr wrote:In that case, you should be able to ping feed.hae.int, and get a response.


I’m not getting a response from that URL.
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby marcelr » Mon Sep 03, 2018 7:56 pm

try
Code: Select all
ping 8.8.8.8

(google) then.
If that doesn't give a response, you don't have a working connection to the outside world.
marcelr
Advanced Member
Advanced Member
 
Posts: 909
Joined: May 2012
Location: Ehv

Re: Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 7:57 pm

marcelr wrote:In that case, you should be able to ping feed.hae.int, and get a response.


When I try to manually start the VPN, I get the following:

Code: Select all
Socket bind failed on local address. [AF_ INET]127.0.0.1:8000 Address already in use.
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby MadDemonoide » Mon Sep 03, 2018 7:57 pm

marcelr wrote:try
Code: Select all
ping 8.8.8.8

(google) then.
If that doesn't give a response, you don't have a working connection to the outside world.


I tried google. I get a nice ping back.
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Re: Toon not booting after failed update

Postby marcelr » Mon Sep 03, 2018 8:12 pm

Maybe you should edit inittab to not start openvpn, then kill it, and let the script do it for you.
marcelr
Advanced Member
Advanced Member
 
Posts: 909
Joined: May 2012
Location: Ehv

Re: Toon not booting after failed update

Postby TheHogNL » Mon Sep 03, 2018 9:06 pm

I think you have a very old version of Toon firmware which doesn't update the /etc/hosts file properly (your feed.hae.int entry in your hosts file doesn't match with the routing table)
Try to remove the "feed.hae.int" line from the /etc/hosts file and restart the Toon and the script again.
TheHogNL
Member
Member
 
Posts: 416
Joined: August 2017

Re: Toon not booting after failed update

Postby MadDemonoide » Tue Sep 04, 2018 1:37 pm

marcelr wrote:Maybe you should edit inittab to not start openvpn, then kill it, and let the script do it for you.


I can start the VPN manually, but it still does not update.
It also shows up @ the top command as a process.
MadDemonoide
Starting Member
Starting Member
 
Posts: 13
Joined: August 2018

Next

Return to Toon issues and support (Nederlands toegestaan)

Who is online

Users browsing this forum: No registered users and 0 guests