Toon only showing current usage, no daily, weekly, monthly?

If your (rooted) Toon doesn't do what it's supposed to, post here. Dutch allowed / Posten in 't Nederlands toegestaan.

Moderators: marcelr, TheHogNL, TerrorSource, Toonz

Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Mon Sep 17, 2018 6:42 am

Hello all,

I rooted a toon from a friend a couple of months ago.
From te beginning this toon is not showing daily, weekly and monthly usage.
It is only showing current usage.

Is there something wrong in a config maybe? My own 2 piece of toons doesn't ever had this issue.

Thanks for helping!.

Regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby TerrorSource » Mon Sep 17, 2018 6:51 am

My guess is that the Toon config settings are not correct.

See: https://www.domoticaforum.eu/viewtopic. ... 235#p83254

Set these settings:
<EndDate>-1</EndDate>
set to: -1
<ProductVariant>Toon</ProductVariant>
"Standalone" or "Toon", value "Standalone" will disable the "full menu" options. Value "Toon" + valid EndDate activates "full menu" options.
set to: Toon
<activated>1</activated>
"0" or "1", activation of the Toon
set to: 1
<wizardDone>1</wizardDone>
"0" or "1", value "0" will activate the "initial setup" screens after a reboot. recommended to use when Toon is sold.
set to: 1
<SortwareUpdates>1</SortwareUpdates>
"0" or "1", value "1" will activate firmware updates.
set to: 1
<ElectricityDisplay>1</ElectricityDisplay>
"0" or "1", displays electricity usage, graphs and options.
set to: 1
<GasDisplay>1</GasDisplay>
"0" or "1", displays gas usage, graphs and options.
set to: 1
TerrorSource
Member
Member
 
Posts: 259
Joined: May 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Mon Sep 17, 2018 6:59 am

Hello Terrorsource,

Thanks for your reply.
I checked the config_happ_scsync.xml file and all the settings are the same you suggesged.
Maybe something else?.

Regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby TerrorSource » Mon Sep 17, 2018 7:15 am

jozg wrote:Hello Terrorsource,

Thanks for your reply.
I checked the config_happ_scsync.xml file and all the settings are the same you suggesged.
Maybe something else?.

Regards,


Normally you need to have an active subscription. Setting the EndDate to -1 will set it to infinity.
Also ProductVariant needs to be set to "Toon". if it's Standalone not all functions will work (like usage history)
ElectricityDisplay and GasDisplay is needed to set the Tile's and the possibility to click on the Tiles to see the usage history.

Did you disable VPN and did a reboot?
TerrorSource
Member
Member
 
Posts: 259
Joined: May 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Mon Sep 17, 2018 7:32 am

Hello Terrorsource,

The VPN is closed and the tiles are showing up.
The enddate is set to -1 and the product variant is also toon. And gas and elec display is set to 1.

I could update using the update script? maybe it helps.

Regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby marcelr » Mon Sep 17, 2018 8:23 am

It's case sensitive, so "Toon", not "toon".
marcelr
Global Moderator
Global Moderator
 
Posts: 1050
Joined: May 2012
Location: Ehv

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Mon Sep 17, 2018 9:01 am

Hello all,

Thanks for helping.
This is a copy/paste from a part of the config_happ_scsync.xml file:

Code: Select all
     <visibility>0</visibility><StartDate>1428883200</StartDate><EndDate>-1</EndDate><ProductVariant>Toon</ProductVariant><activated>1</activated><wizardDone>1</wizardDone><SoftwareUpdates>1</SoftwareUpdates><ElectricityDisplay>1</ElectricityDisplay><GasDisplay>1</GasDisplay><HeatDisplay>0</HeatDisplay><SolarDisplay>1</SolarDisplay><SolarActivated>1</SolarActivated><OtherProviderElec>1</OtherProviderElec><OtherProviderGas>1</OtherProviderGas><SME>0</SME><HeatWinner>0</HeatWinner><ContentApps>0</ContentApps><TelmiEnabled>0</TelmiEnabled><mobileAccess>1</mobileAccess><supportEnabled>0</supportEnabled><supportEnabledStart>0</supportEnabledStart><researchEnabled>0</researchEnabled><doSolarWhatsnew>0</doSolarWhatsnew><latestWhatsnewVersion>qt-gui - 1.7978-ene-hotfix-4.9</latestWhatsnewVersion><statusUsageFirstUse>0</statusUsageFirstUse><scStatusFlags>0</scStatusFlags><commissionState>0</commissionState></device>


I think it should be fine?.

Regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby TerrorSource » Mon Sep 17, 2018 12:58 pm

Is there a physical ZonOpTon or other Kwh-meter present? if not, set SolarActivated and SolarDisplay to 0.
Have you tried changing OtherProviderGas and OtherProviderElec to 0 as well ? Dont have a Toon preset but i thought that those value's are 0 in my Toon.
TerrorSource
Member
Member
 
Posts: 259
Joined: May 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Mon Sep 17, 2018 1:48 pm

Hello Terrorsource,

I'll try, and let you know.
Thanks.

Regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby Toonz » Mon Sep 17, 2018 2:52 pm

Also, try this : <EndDate>1627485995</EndDate>
I found that the enddate of -1 not always give the desired results
member of the Toon Software Collective
User avatar
Toonz
Forum Moderator
Forum Moderator
 
Posts: 1081
Joined: December 2016

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Mon Sep 17, 2018 6:18 pm

Thanks for the tips.

It looks like it's working, but today usage, is shown as shaded.
I'll check tomorrow when this day is over.

Regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby Rudolf » Tue Sep 18, 2018 10:31 am

The shaded bar for this day/week/month is normal behaviour. It's Toon's way of saying this value is subject to change.
Previous days/weeks/months will be shown as a solid blue bar.
Rudolf
Member
Member
 
Posts: 116
Joined: December 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby jozg » Wed Sep 19, 2018 6:49 am

Hello All,

It helped, thanks!.
Another question, i have this one "to test" so i connected it to my P1 port.
Now it thinks it used monday (when i connected it) almost 6000KwH, because i have an other P1 port then my friend.

Is there a way to delete or change the incorrect usage (because of the other meter) before i give it back.
He lives 200km's from my home.

Or is the only way to do factory reset, and connect the meter adapter again in the house from my friend?
What i remembered from a factory reset that some of the files are "empty" again,wich files are overwritten? so i can make backups from it.

Thanks.

regards,
jozg
Starting Member
Starting Member
 
Posts: 40
Joined: November 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby TerrorSource » Wed Sep 19, 2018 8:42 am

jozg wrote:Hello All,

It helped, thanks!.
Another question, i have this one "to test" so i connected it to my P1 port.
Now it thinks it used monday (when i connected it) almost 6000KwH, because i have an other P1 port then my friend.

Is there a way to delete or change the incorrect usage (because of the other meter) before i give it back.
He lives 200km's from my home.

Or is the only way to do factory reset, and connect the meter adapter again in the house from my friend?
What i remembered from a factory reset that some of the files are "empty" again,wich files are overwritten? so i can make backups from it.

Thanks.

regards,


it should be possible to remove the rrd database with the p1 values but the easiest is just to reset to factory reset.
TerrorSource
Member
Member
 
Posts: 259
Joined: May 2017

Re: Toon only showing current usage, no daily, weekly, monthly?

Postby richardklasens » Wed May 01, 2019 7:39 pm

Hi Guys.

Small question,

I’ve recently stopped my subscription with Eneco and since the official end date, My tiles for power/gas usage daily/monthly/yearly are gone. I’ve checked the file config_happ_scsync.xml but there are no lines with activation/product/electric/gas etc. Can i just add them as shown in the copied code as shown above?

Thnx!
richardklasens
Starting Member
Starting Member
 
Posts: 15
Joined: February 2019

Next

Return to Toon issues and support (Nederlands toegestaan)

Who is online

Users browsing this forum: No registered users and 0 guests