Hardware: Toon boiler module, "ketelmodule"

Forum about Toon hardware, both versions 1 and 2 of Toon

Moderator: marcelr

Re: Hardware: Toon boiler module, "ketelmodule"

Postby Smiggel » Sun Apr 29, 2018 8:15 pm

TheHogNL wrote:
Smiggel wrote:
marcelr wrote:No. factory reset just clears all data from toon, regarding electricity consumption and the likes. OT support has got nothing to do with it.

There is a possibility that you need to try and force Toon to do OT support for quite a few times. For my Nefit, I had to push the button on Toon several times before it decided that OT support was possible after all.
For the exact type, just look at the rear of the module. If you bought your Toon from a trader, module and display may not have belonged together.


I check the device number op the device. It's 6500-1200-4801 according to the sticker on the device.

How do I force it? I don't seem to have the option to do that. I've attached a picture with what I see in the settings page.



Your picture is showing a 'heating' configuration of Toon (like 'stadsverwarming') instead of a boiler configuration. You probably screwed up your settings (i think the scsync file, check it there).


What exactly am I looking for then. Can you tell me that?
Smiggel
Starting Member
Starting Member
 
Posts: 28
Joined: April 2018

Re: Hardware: Toon boiler module, "ketelmodule"

Postby marcelr » Sun Apr 29, 2018 8:40 pm

You will be looking for tags related to heating in config_happ_scsync.xml.
marcelr
Advanced Member
Advanced Member
 
Posts: 925
Joined: May 2012
Location: Ehv

Re: Hardware: Toon boiler module, "ketelmodule"

Postby TheHogNL » Sun Apr 29, 2018 8:52 pm

Please paste the line from that file (the whole line where StartDate and EndDate is in)
TheHogNL
Member
Member
 
Posts: 446
Joined: August 2017

Re: Hardware: Toon boiler module, "ketelmodule"

Postby Smiggel » Sun Apr 29, 2018 9:08 pm

@marcelr & @TheHogNL I found it! :-)

This line was still in there: <uuid>eneco-xxx-xxxxxx:happ_scsync_xxxxxxxxxx</uuid>. I replaced the numbers by x's. I think it was still a mention of the old contract of the previous owner. I removed that line and then rebooted. Had to adjust some settings again in the config_happ_scsync.xml file and set Toon as activated, etc. and now it's working. It sees the OT now and it's all working perfectly now. :-)

Thanks for helping me out so far.
Smiggel
Starting Member
Starting Member
 
Posts: 28
Joined: April 2018

Re: Hardware: Toon boiler module, "ketelmodule"

Postby mAiden » Sun Apr 29, 2018 9:09 pm

so funny. Eneco say that Toon does not work correctly with ’stadsverwarming’, but more and more Toons are on Warmte.
mAiden
Member
Member
 
Posts: 72
Joined: July 2017

Re: Hardware: Toon boiler module, "ketelmodule"

Postby Smiggel » Sun Apr 29, 2018 9:12 pm

mAiden wrote:so funny. Eneco say that Toon does not work correctly with ’stadsverwarming’, but more and more Toons are on Warmte.


I have no idea. This was something of the previous owner I guess. :-)
Smiggel
Starting Member
Starting Member
 
Posts: 28
Joined: April 2018

Re: Hardware: Toon boiler module, "ketelmodule"

Postby TheHogNL » Sun Apr 29, 2018 9:15 pm

mAiden wrote:so funny. Eneco say that Toon does not work correctly with ’stadsverwarming’, but more and more Toons are on Warmte.


The code is still there only they don't provide the option anymore. It is easily being enabled again.
The only thing that changes when you enabled heating is that it disables opentherm (duh, ofcourse) and the ketelmodule output is then fixed at on/off. So you can connect a 12-24v relais to it to switch on or off a 2-way valve for a 'stadverwarming' installation.

The reason that Eneco stopt with this is that they couldn't provide the correct heating usage details (like gas usage for a boiler heater).

Nice fact,.. I'm using the Toon to switch on/off my heatpump. Works just fine. No support whatsoever ofcourse :)
TheHogNL
Member
Member
 
Posts: 446
Joined: August 2017

Re: Hardware: Toon boiler module, "ketelmodule"

Postby Bammetje » Sun Jun 10, 2018 8:32 pm

Smiggel wrote:@marcelr & @TheHogNL I found it! :-)

This line was still in there: <uuid>eneco-xxx-xxxxxx:happ_scsync_xxxxxxxxxx</uuid>. I replaced the numbers by x's. I think it was still a mention of the old contract of the previous owner. I removed that line and then rebooted. Had to adjust some settings again in the config_happ_scsync.xml file and set Toon as activated, etc. and now it's working. It sees the OT now and it's all working perfectly now. :-)

Thanks for helping me out so far.


Hi Smiggel,

I have exactly the same issue where Toon only shows 'warmte'. As soon as I remove the <uuid> line I can set it to opentherm. However, my Toon starts to ask for activation every time. Even though I have <activated> set to 1 in config_happ_scsync.xml. Can you tell me what I'm forgetting to change and how you removed the activation screen?

Hoping to hear from you.
Bammetje
Starting Member
Starting Member
 
Posts: 2
Joined: June 2018

Re: Hardware: Toon boiler module, "ketelmodule"

Postby TheHogNL » Mon Jun 11, 2018 10:21 pm

You can try to (first make a copy) to remove the scsync file and fire up your openvpn. The service center will then create a new scsync file for you, containing no contract whatsoever. Then you can change the dates etc again and hopefully it will work then.
TheHogNL
Member
Member
 
Posts: 446
Joined: August 2017

Re: Hardware: Toon boiler module, "ketelmodule"

Postby Bammetje » Tue Jun 12, 2018 7:45 pm

TheHogNL wrote:You can try to (first make a copy) to remove the scsync file and fire up your openvpn. The service center will then create a new scsync file for you, containing no contract whatsoever. Then you can change the dates etc again and hopefully it will work then.


Thanks! That was spot on. (Actually already did so by accident :)) However for other users: I can confirm that this is the solution for a Toon that is stuck to "Warmte".
Bammetje
Starting Member
Starting Member
 
Posts: 2
Joined: June 2018

Previous

Return to Toon Hardware

Who is online

Users browsing this forum: No registered users and 0 guests

cron