Installation of Zenah

Forum regarding Linux Software and Home Automation Domotica.

Installation of Zenah

Postby gb1980 » Tue Jan 22, 2008 1:53 pm

Hi,

I've followed the Zenah installation on http://wiki.binkey.nl/Zenah.
I run debian in vmware:
# uname -a
Linux debian-dev 2.6.18-5-686
#1 SMP Mon Dec 24 16:41:07 UTC 2007 i686 GNU/Linux

When I want to run zenah, I get the following error:

# perl -Iblib/lib blib/script/zenah
Couldn't require loader class "Class::DBI::Loader::mysql", "Can't locate Class/DBI/mysql.pm in @INC (@INC contains: blib/lib /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/Class/DBI/Loader/mysql.pm line 9.
Compilation failed in require at (eval 163) line 2.
BEGIN failed--compilation aborted at (eval 163) line 2.
" at /usr/share/perl5/Class/DBI/Loader.pm line 82.
Compilation failed in require at blib/lib/ZenAH/Engine.pm line 44.
BEGIN failed--compilation aborted at blib/lib/ZenAH/Engine.pm line 44.
Compilation failed in require at blib/script/zenah line 35.
BEGIN failed--compilation aborted at blib/script/zenah line 35.

STRACE OUTPUT:
# strace perl -Iblib/lib blib/script/zenah
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.8/i486-linux-gnu-thread-multi", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.8", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/i486-linux-gnu-thread-multi", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.7", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.6", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.4", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.3", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.2", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.1", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("blib/lib/5.8.0", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/site_perl/5.8.8/i486-linux-gnu-thread-multi", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/site_perl/5.8.8", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/site_perl/i486-linux-gnu-thread-multi", 0xbfbe7d10) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.7", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.7", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.6", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.6", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.4", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.4", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.3", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.3", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.2", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.2", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.1", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.1", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.0", 0xbfbe7e80) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.0", 0xbfbe7e80) = -1 ENOENT (No such file or directory)

stat64("blib/lib/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/etc/perl/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/etc/perl/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.8/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/usr/local/lib/perl/5.8.8/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.8/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/usr/local/share/perl/5.8.8/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/perl5/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/perl5/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/usr/share/perl5/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/usr/share/perl5/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/perl/5.8/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/usr/lib/perl/5.8/strict.pm", 0xbfbe783c) = -1 ENOENT (No such file or directory)
stat64("/usr/share/perl/5.8/strict.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("/usr/share/perl/5.8/strict.pm", {st_mode=S_IFREG|0644, st_size=599, ...}) = 0
open("/usr/share/perl/5.8/strict.pm", O_RDONLY|O_LARGEFILE) = 4

Also the above messages for the following files: (is it normal?)
stat64("blib/lib/warnings.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/Carp.pmc", 0xbfbe749c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/Exporter.pmc", 0xbfbe749c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/English.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/Exporter/Heavy.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/FileHandle.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/IO/File.pmc", 0xbfbe792c) = -1 ENOENT (No such file or directory)
stat64("blib/lib/Symbol.pmc", 0xbfbe749c) = -1 ENOENT (No such file or directory)

The main complaining from above:
Couldn't require loader class "Class::DBI::Loader::mysql", "Can't locate Class/DBI/mysql.pm

But I've installed it in cpan:
cpan[6]> install Class::DBI::Loader::mysql
Class::DBI::Loader::mysql is up to date (0.30).

Maybe someone can point me in the right direction.
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby Snelvuur » Tue Jan 22, 2008 1:56 pm

If this is debian then you can just apt-get the missing ones. I think i have the whole list on the wiki of packages you need. otherwise you need to install them seperately. I dont use cpan though, normally i would do the perl MakeFile.PL or something then the install. Or just make it and make sure my environments point to this dir aswell.

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Wed Jan 23, 2008 11:30 pm

Hi Snelvuur,
I've tried and tried getting Zenah up@running.
So, I've stopped using mysql, did some complete new installs, and got it almost running.
I think I miss the perl library for xPL::Timer::sunset because it could not locate Sunrise.pm

The next lines are all my loggings and findings.
I hope it can help somebody, and maybe you know how I can get the xPL::Timer::sunset.
I've used Debian 4.0r2 i386 release, with a standard install (deselected desktop in installation)

I also had to change some of the apt-get things as your installation how-to probably is written for an older debian configuration.

-----------------
From the list:
apt-get install libxpl-perl librrds-perl libdatetime-event-sunrise-perl libdatetime-event-recurrence-perl libtimedate-perl rrdtool hddtemp libmodule-install-perl libcatalyst-perl libtemplate-perl libdbd-sqlite3-perl libclass-dbi-sqlite-perl libclass-dbi-loader-relationship-perl libclass-dbi-asform-perl libclass-dbi-fromform-perl libcatalyst-plugin-formvalidator-perl libdatetime-format-strptime-perl libclass-dbi-sweet-perl libtemplate-perl libcatalyst-modules-perl

I could not install: libclass-dbi-sweet-perl libdatetime-event-sunrise-perl libdatetime-event-recurrence-perl libtimedate-perl (I think this is also my problem in the end)

apt-get install libyaml-perl (as this was required for libxpl
dpkg -i libxpl-perl_0.06-1_all.deb
apt-get install libdatetime-locale-perl libdatetime-perl libdatetime-timezone-perl

This was the command to install the others:
apt-get install librrds-perl rrdtool hddtemp libmodule-install-perl libcatalyst-perl libtemplate-perl libdbd-sqlite3-perl libclass-dbi-sqlite-perl libclass-dbi-loader-relationship-perl libclass-dbi-asform-perl libclass-dbi-fromform-perl libcatalyst-plugin-formvalidator-perl libdatetime-format-strptime-perl libtemplate-perl libcatalyst-modules-perl

And the following NEW packages will be installed:
defoma hddtemp libalgorithm-c3-perl libappconfig-perl libarchive-tar-perl libart-2.0-2 libbit-vector-perl
libcache-cache-perl libcache-fastmmap-perl libcarp-assert-more-perl libcarp-assert-perl libcarp-clan-perl
libcatalyst-modules-perl libcatalyst-perl libcatalyst-plugin-formvalidator-perl libcatalyst-view-tt-perl
libcgi-simple-perl libcgi-untaint-perl libclass-accessor-chained-perl libclass-accessor-perl libclass-c3-perl
libclass-data-accessor-perl libclass-data-inheritable-perl libclass-dbi-asform-perl libclass-dbi-fromcgi-perl
libclass-dbi-fromform-perl libclass-dbi-loader-perl libclass-dbi-loader-relationship-perl libclass-dbi-perl
libclass-dbi-plugin-type-perl libclass-dbi-sqlite-perl libclass-inspector-perl libclass-throwable-perl
libclass-trigger-perl libclone-perl libcompress-zlib-perl libconfig-any-perl libdata-dump-perl
libdata-formvalidator-perl libdata-page-perl libdata-visitor-perl libdate-calc-perl libdatetime-format-strptime-perl
libdbd-sqlite3-perl libdbi-perl libdbix-class-perl libdbix-class-schema-loader-perl libdbix-contextualfetch-perl
libdevel-stacktrace-perl libdigest-hmac-perl libdigest-sha1-perl libemail-valid-perl liberror-perl libexpat1
libexporter-lite-perl libextutils-autoinstall-perl libextutils-cbuilder-perl libextutils-parsexs-perl
libfile-copy-recursive-perl libfile-mmagic-perl libfile-modified-perl libfile-slurp-perl libfreetype6
libhtml-parser-perl libhtml-prototype-perl libhtml-scrubber-perl libhtml-tagset-perl libhtml-tree-perl
libhtml-widget-perl libhttp-body-perl libhttp-request-ascgi-perl libhttp-server-simple-perl libima-dbi-perl
libimage-size-perl libio-stringy-perl libio-zlib-perl libipc-sharelite-perl libjson-perl
liblingua-en-inflect-number-perl liblingua-en-inflect-perl liblocale-maketext-lexicon-perl
liblocale-maketext-simple-perl liblog-log4perl-perl libmailtools-perl libmime-types-perl libmodule-build-perl
libmodule-find-perl libmodule-install-perl libmodule-pluggable-fast-perl libmodule-scandeps-perl libnet-daemon-perl
libnet-dns-perl libnet-domain-tld-perl libnet-ip-perl libobject-signature-perl libossp-uuid-perl libossp-uuid15
libpar-dist-perl libpath-class-perl libplrpc-perl libpng12-0 libregexp-common-perl librpc-xml-perl librrd2 librrds-perl
libset-object-perl libsql-abstract-limit-perl libsql-abstract-perl libsqlite3-0 libsub-uplevel-perl libtemplate-perl
libtemplate-plugin-class-perl libtemplate-timer-perl libtest-exception-perl libtest-longstring-perl
libtest-mockobject-perl libtest-use-ok-perl libtest-www-mechanize-perl libtext-simpletable-perl libtie-ixhash-perl
libtimedate-perl libtree-simple-perl libtree-simple-visitorfactory-perl libuniversal-can-perl libuniversal-exports-perl
libuniversal-isa-perl libuniversal-moniker-perl libuniversal-require-perl liburi-perl libversion-perl
libwww-mechanize-perl libwww-perl libxml-parser-perl rrdtool ttf-dejavu

apt-get install subversion

svn co http://www.zenah.org.uk/svn/zenah/trunk zenah

cd zenah

reading README

apt-get install sqlite3 unzip make lynx ncftp ncftp2

sqlite3 zenah.sample.db <zenah.sample.sql3
cp -p zenah.sample.db zenah.db

perl Makefile.PL

Warning: prerequisite Class::DBI::Sweet 0 not found.
Warning: prerequisite Template::Provider 2.93 not found. We have 2.810.

cpan
install Bundle::CPAN
install Bundle::DBI

changing CPAN source to: ftp://ftp.quicknet.nl/pub/CPAN/

i /Sweet/
install Class::DBI::Sweet
install Template::Provider

#perl Makefile.PL
output:
include /download/zenah/inc/Module/Install.pm
include inc/Module/Install/Metadata.pm
include inc/Module/Install/Base.pm
Cannot determine perl version info from lib/ZenAH.pm
include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.
include inc/Module/Install/Scripts.pm
include inc/Module/Install/AutoInstall.pm
include inc/Module/Install/Include.pm
include inc/Module/AutoInstall.pm
*** Module::AutoInstall version 1.030
*** Checking for Perl dependencies...
[Core Features]
- Module::Install ...loaded. (0.640)
- DBD::SQLite ...loaded. (1.130)
- Class::DBI::SQLite ...loaded. (0.110)
- Test::More ...loaded. (0.740)
- Catalyst ...missing. (would need 5.64)
- Template::Provider ...missing. (would need 2.93)
- xPL::Base ...loaded. (0.060 >= 0.05)
- Catalyst::Plugin::FormValidator ...loaded. (0.020)
- Catalyst::Plugin::SubRequest ...loaded. (0.100)
- Class::DBI::FromForm ...loaded. (0.040)
- Class::DBI::AsForm ...loaded. (2.420)
- Class::DBI::Loader ...loaded. (0.330)
- Class::DBI::Loader::Relationship ...loaded. (1.300)
- Class::DBI::Sweet ...loaded. (0.090)
- DateTime::Format::Strptime ...loaded. (1.070000)
- Template::Plugin::Class ...loaded. (0.130)
==> Auto-install the 2 mandatory module(s) from CPAN? [y] y
CPAN: File::HomeDir loaded ok (v0.67)
*** Dependencies will be installed the next time you type 'make'.
*** Module::AutoInstall configuration finished.
include inc/Module/Install/WriteAll.pm
Writing META.yml
include inc/Module/Install/Win32.pm
include inc/Module/Install/Can.pm
include inc/Module/Install/Fetch.pm
Warning: prerequisite Catalyst 5.64 not found. We have unknown version.
Warning: prerequisite Template::Provider 2.93 not found. We have 2.810.
Writing Makefile for ZenAH

export LONGITUDE=5.7667
export LATITUDE=50.9500
export TZ=Europe/Amsterdam



#perl -Iblib/lib blib/script/zenah

output:
closing dbh with active statement handles at /usr/share/perl5/Class/DBI/Loader/SQLite.pm line 110.
Adding trigger type: xpl
Adding action type: xpl
Adding trigger type: scene
Adding action type: scene
Adding action type: sleep
Adding trigger type: at
Adding stash variable: datetime
Adding stash variable: device
Adding action type: device
Adding stash variable: history
Adding stash variable: state
Adding stash variable: map
Adding stash variable: room
Adding action type: enable
Adding action type: disable
Adding action type: debug
Adding action type: error
Done.

Adding rule: cuckoo
xPL::Timer->new: Failed to load xPL::Timer::recurrence: Can't locate DateTime/Event/Recurrence.pm in @INC (@INC contains: blib/lib /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/xPL/Timer/recurrence.pm line 28.
BEGIN failed--compilation aborted at /usr/share/perl5/xPL/Timer/recurrence.pm line 28.
Compilation failed in require at (eval 217) line 1.

at /usr/share/perl5/xPL/Timer.pm line 100.


cpan
install DateTime::Event::Recurrence


HA01:/download/zenah# perl -Iblib/lib blib/script/zenah
closing dbh with active statement handles at /usr/share/perl5/Class/DBI/Loader/SQLite.pm line 110.
Adding trigger type: xpl
Adding action type: xpl
Adding trigger type: scene
Adding action type: scene
Adding action type: sleep
Adding trigger type: at
Adding stash variable: datetime
Adding stash variable: device
Adding action type: device
Adding stash variable: history
Adding stash variable: state
Adding stash variable: map
Adding stash variable: room
Adding action type: enable
Adding action type: disable
Adding action type: debug
Adding action type: error
Done.

Adding rule: cuckoo
Adding rule: x10lamp_trigger
K: class => x10
K: class_type => basic
K: command => (on|off|bright|dim)
K: message_type => xpl-trig
Adding rule: x10app_trigger
K: class => x10
K: class_type => basic
K: command => (on|off)
K: message_type => xpl-trig
Adding rule: dusk
xPL::Timer->new: Failed to load xPL::Timer::sunset: Can't locate DateTime/Event/Sunrise.pm in @INC (@INC contains: blib/lib /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/xPL/Timer/sunset.pm line 28.
BEGIN failed--compilation aborted at /usr/share/perl5/xPL/Timer/sunset.pm line 28.
Compilation failed in require at (eval 219) line 1.

at /usr/share/perl5/xPL/Timer.pm line 100.
HA01:/download/zenah#

vi /etc/apt/sources.list
adding: deb http://www.xpl-perl.org.uk/download/debian ./
apt-get update
apt-get upgrade
Setting up libtemplate-perl (2.19-1) ...
Setting up libxpl-perl (0.06-1) ...


HA01:/download/zenah# perl -Iblib/lib blib/script/zenah
closing dbh with active statement handles at /usr/share/perl5/Class/DBI/Loader/SQLite.pm line 110.
Adding trigger type: xpl
Adding action type: xpl
Adding trigger type: scene
Adding action type: scene
Adding action type: sleep
Adding trigger type: at
Adding stash variable: datetime
Adding stash variable: device
Adding action type: device
Adding stash variable: history
Adding stash variable: state
Adding stash variable: map
Adding stash variable: room
Adding action type: enable
Adding action type: disable
Adding action type: debug
Adding action type: error
Done.

Adding rule: cuckoo
Adding rule: x10lamp_trigger
K: class => x10
K: class_type => basic
K: command => (on|off|bright|dim)
K: message_type => xpl-trig
Adding rule: x10app_trigger
K: class => x10
K: class_type => basic
K: command => (on|off)
K: message_type => xpl-trig
Adding rule: dusk
xPL::Timer->new: Failed to load xPL::Timer::sunset: Can't locate DateTime/Event/Sunrise.pm in @INC (@INC contains: blib/lib /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/xPL/Timer/sunset.pm line 28.
BEGIN failed--compilation aborted at /usr/share/perl5/xPL/Timer/sunset.pm line 28.
Compilation failed in require at (eval 206) line 1.

at /usr/share/perl5/xPL/Timer.pm line 98.
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby Snelvuur » Thu Jan 24, 2008 8:35 am

try adding the sources.list the one from xpl-perl (deb http://www.xpl-perl.org.uk/download/debian ./)

then try and fetch libclass-dbi-sweet-perl libdatetime-event-sunrise-perl libdatetime-event-recurrence-perl libtimedate-perl those.

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Thu Jan 24, 2008 6:32 pm

You're the man !!!
now we're getting something, and I've got my smile back again :D.

When I understand the package, I will document it with the findings I've posted before.

at least the box says to me:

Triggering motion_check
Triggering motion_check
Triggering cuckoo
Action: xpl -c osd.basic command=clear text="It is 18:30" delay=10
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Thu Jan 24, 2008 6:56 pm

Just checking out the frontend not, also not without a chalenge ;)
It stops because of the "catalyst" stuff, and ofcourse I could have know this with perl Makefile.pm as it gave errors.
Unfortunatly I have to find out how I can install just tjis 5.64 version as it is very picky about it.


HA01:/download/zenah# perl -Iblib/lib blib/script/zenah_server.pl
Weak references are not implemented in the version of perl at /usr/share/perl5/Catalyst.pm line 22
BEGIN failed--compilation aborted at /usr/share/perl5/Catalyst.pm line 22.
Compilation failed in require at /download/zenah/blib/script/../lib/ZenAH.pm line 14.
BEGIN failed--compilation aborted at /download/zenah/blib/script/../lib/ZenAH.pm line 14.
Compilation failed in require at blib/script/zenah_server.pl line 56.

HA01:/download/zenah# perl Makefile.PL
include /download/zenah/inc/Module/Install.pm
include inc/Module/Install/Metadata.pm
include inc/Module/Install/Base.pm
Cannot determine perl version info from lib/ZenAH.pm
include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.
include inc/Module/Install/Scripts.pm
include inc/Module/Install/AutoInstall.pm
include inc/Module/Install/Include.pm
include inc/Module/AutoInstall.pm
*** Module::AutoInstall version 1.030
*** Checking for Perl dependencies...
[Core Features]
- Module::Install ...loaded. (0.640)
- DBD::SQLite ...loaded. (1.130)
- Class::DBI::SQLite ...loaded. (0.110)
- Test::More ...loaded. (0.740)
- Catalyst ...missing. (would need 5.64)
- Template::Provider ...loaded. (2.930 >= 2.93)
- xPL::Base ...loaded. (0.060 >= 0.05)
- Catalyst::Plugin::FormValidator ...loaded. (0.020)
- Catalyst::Plugin::SubRequest ...loaded. (0.100)
- Class::DBI::FromForm ...loaded. (0.040)
- Class::DBI::AsForm ...loaded. (2.420)
- Class::DBI::Loader ...loaded. (0.330)
- Class::DBI::Loader::Relationship ...loaded. (1.300)
- Class::DBI::Sweet ...loaded. (0.090)
- DateTime::Format::Strptime ...loaded. (1.070000)
- Template::Plugin::Class ...loaded. (0.130)
==> Auto-install the 1 mandatory module(s) from CPAN? [y]

the auto install won't help...
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Thu Jan 24, 2008 6:57 pm

output of the auto install:

CPAN: File::HomeDir loaded ok (v0.67)
*** Dependencies will be installed the next time you type 'make'.
*** Module::AutoInstall configuration finished.
include inc/Module/Install/WriteAll.pm
Writing META.yml
include inc/Module/Install/Win32.pm
include inc/Module/Install/Can.pm
include inc/Module/Install/Fetch.pm
Warning: prerequisite Catalyst 5.64 not found. We have unknown version.
Writing Makefile for ZenAH
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Thu Jan 24, 2008 7:24 pm

trying to install the manual way:
wget ftp://62.201.161.82/pub/CPAN/modules/by ... .64.tar.gz
tar -zxf Catalyst-5.64.tar.gz
cd Catalyst-5.64
perl Makefile.PL
make
perl -MCPANPLUS -e 'install Task::Catalyst'
apt-get install libcatalyst-perl
apt-get install libcatalyst-engine-apache-perl
make install
cd zenah/
perl Makefile.PL
make

also tried with:
wget http://search.cpan.org/CPAN/authors/id/ ... 012.tar.gz
etc. etc.

result:

# perl Makefile.PL

include /download/zenah/inc/Module/Install.pm
include inc/Module/Install/Metadata.pm
include inc/Module/Install/Base.pm
Cannot determine perl version info from lib/ZenAH.pm
include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.
include inc/Module/Install/Scripts.pm
include inc/Module/Install/AutoInstall.pm
include inc/Module/Install/Include.pm
include inc/Module/AutoInstall.pm
*** Module::AutoInstall version 1.030
*** Checking for Perl dependencies...
[Core Features]
- Module::Install ...loaded. (0.640)
- DBD::SQLite ...loaded. (1.130)
- Class::DBI::SQLite ...loaded. (0.110)
- Test::More ...loaded. (0.740)
- Catalyst ...missing. (would need 5.64)
- Template::Provider ...loaded. (2.930 >= 2.93)
- xPL::Base ...loaded. (0.060 >= 0.05)
- Catalyst::Plugin::FormValidator ...loaded. (0.020)
- Catalyst::Plugin::SubRequest ...loaded. (0.100)
- Class::DBI::FromForm ...loaded. (0.040)
- Class::DBI::AsForm ...loaded. (2.420)
- Class::DBI::Loader ...loaded. (0.330)
- Class::DBI::Loader::Relationship ...loaded. (1.300)
- Class::DBI::Sweet ...loaded. (0.090)
- DateTime::Format::Strptime ...loaded. (1.070000)
- Template::Plugin::Class ...loaded. (0.130)
==> Auto-install the 1 mandatory module(s) from CPAN? [y] y
CPAN: File::HomeDir loaded ok (v0.67)
*** Dependencies will be installed the next time you type 'make'.
*** Module::AutoInstall configuration finished.
include inc/Module/Install/WriteAll.pm
Writing META.yml
include inc/Module/Install/Win32.pm
include inc/Module/Install/Can.pm
include inc/Module/Install/Fetch.pm
Warning: prerequisite Catalyst 5.64 not found. We have unknown version.
Writing Makefile for ZenAH
HA01:/download/zenah# make
/usr/bin/perl "-Iinc" Makefile.PL --config= --installdeps=Catalyst,5.64
include /download/zenah/inc/Module/Install.pm
include inc/Module/Install/Metadata.pm
include inc/Module/Install/Base.pm
Cannot determine perl version info from lib/ZenAH.pm
include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.
include inc/Module/Install/Scripts.pm
include inc/Module/Install/AutoInstall.pm
include inc/Module/Install/Include.pm
include inc/Module/AutoInstall.pm
CPAN: File::HomeDir loaded ok (v0.67)
*** Installing dependencies...
*** Installing Catalyst...
CPAN: Storable loaded ok (v2.15)
Going to read /root/.cpan/Metadata
Database was generated on Wed, 23 Jan 2008 18:30:48 GMT
Catalyst is up to date (5.7012).
*** Catalyst installation failed.
*** Module::AutoInstall installation finished.
cp script/zenah_server.pl blib/script/zenah_server.pl
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/zenah_server.pl
cp script/zenah_create.pl blib/script/zenah_create.pl
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/zenah_create.pl
cp script/zenah_test.pl blib/script/zenah_test.pl
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/zenah_test.pl
cp bin/zenah blib/script/zenah
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/zenah
cp script/zenah_fastcgi.pl blib/script/zenah_fastcgi.pl
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/zenah_fastcgi.pl
cp bin/hr10-label blib/script/hr10-label
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/hr10-label
cp script/zenah_cgi.pl blib/script/zenah_cgi.pl
/usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/zenah_cgi.pl
Manifying blib/man1/zenah_server.pl.1p
Manifying blib/man1/zenah_create.pl.1p
Manifying blib/man1/zenah_test.pl.1p
Manifying blib/man1/zenah.1p
Manifying blib/man1/zenah_fastcgi.pl.1p
Manifying blib/man1/hr10-label.1p
Manifying blib/man1/zenah_cgi.pl.1p
Manifying blib/man3/ZenAH::Engine::Plugin::Rooms.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::Timer.3pm
Manifying blib/man3/ZenAH::Model::CDBI.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::State.3pm
Manifying blib/man3/ZenAH::Templates.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::Devices.3pm
Manifying blib/man3/ZenAH::CDBI.3pm
Manifying blib/man3/ZenAH::View::Site.3pm
Manifying blib/man3/ZenAH.3pm
Manifying blib/man3/ZenAH::Controller::Admin::History.3pm
Manifying blib/man3/ZenAH::Controller::Admin::Room.3pm
Manifying blib/man3/ZenAH::Controller::Admin::Rule.3pm
Manifying blib/man3/ZenAH::Engine.3pm
Manifying blib/man3/ZenAH::View::UI.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::History.3pm
Manifying blib/man3/ZenAH::Controller::Admin::Device.3pm
Manifying blib/man3/ZenAH::Controller::Admin::Template.3pm
Manifying blib/man3/ZenAH::Controller::Admin::Map.3pm
Manifying blib/man3/ZenAH::Controller::UI.3pm
Manifying blib/man3/ZenAH::Controller::Admin::DeviceAttribute.3pm
Manifying blib/man3/ZenAH::Controller::Admin::DeviceControl.3pm
Manifying blib/man3/ZenAH::Controller::Admin::State.3pm
Manifying blib/man3/ZenAH::Controller::Admin::RoomAttribute.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::Maps.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::Scene.3pm
Manifying blib/man3/ZenAH::Controller::Admin.3pm
Manifying blib/man3/ZenAH::Engine::Plugin::xPL.3pm


# make install

/usr/bin/perl "-Iinc" Makefile.PL --config= --installdeps=Catalyst,5.64
include /download/zenah/inc/Module/Install.pm
include inc/Module/Install/Metadata.pm
include inc/Module/Install/Base.pm
Cannot determine perl version info from lib/ZenAH.pm
include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.
include inc/Module/Install/Scripts.pm
include inc/Module/Install/AutoInstall.pm
include inc/Module/Install/Include.pm
include inc/Module/AutoInstall.pm
CPAN: File::HomeDir loaded ok (v0.67)
*** Installing dependencies...
*** Installing Catalyst...
CPAN: Storable loaded ok (v2.15)
Going to read /root/.cpan/Metadata
Database was generated on Wed, 23 Jan 2008 18:30:48 GMT
Catalyst is up to date (5.7012).
*** Catalyst installation failed.
*** Module::AutoInstall installation finished.
Installing /usr/local/share/perl/5.8.8/ZenAH/zenah.db
Writing /usr/local/lib/perl/5.8.8/auto/ZenAH/.packlist
Appending installation info to /usr/lib/perl/5.8/perllocal.pod

# perl -Iblib/lib blib/script/zenah_server.pl

Weak references are not implemented in the version of perl at /usr/local/share/perl/5.8.8/Catalyst.pm line 24
BEGIN failed--compilation aborted at /usr/local/share/perl/5.8.8/Catalyst.pm line 24.
Compilation failed in require at /download/zenah/blib/script/../lib/ZenAH.pm line 14.
BEGIN failed--compilation aborted at /download/zenah/blib/script/../lib/ZenAH.pm line 14.
Compilation failed in require at blib/script/zenah_server.pl line 56.

So, no go.
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby Snelvuur » Thu Jan 24, 2008 8:37 pm

isn't that "apt-get install libcatalyst-modules-perl" ? i see now that i did not include a list of apt-gets for zenah.. i do know that you should either use all the perl modules from apt-get or the ones from cpan , but for debian one should really only do apt-get.

Did you also do "make clean" after a new try? You should get

include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst

Try this list of apt-get's which i still found.

apt-get install librrds-perl libdatetime-event-sunrise-perl libdatetime-event-recurrence-perl libtimedate-perl rrdtool hddtemp libmodule-install-perl libcatalyst-perl libtemplate-perl libdbd-sqlite3-perl libclass-dbi-sqlite-perl libclass-dbi-loader-relationship-perl libclass-dbi-asform-perl libclass-dbi-fromform-perl libcatalyst-plugin-formvalidator-perl libdatetime-format-strptime-perl libclass-dbi-sweet-perl libtemplate-perl libcatalyst-modules-perl

And if you find the solution now, please change the wiki if you feel up to it. So i can direct the next person to a working one. The xpl-perl explanations where ok right?

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Fri Jan 25, 2008 12:02 am

HA01:~# apt-get install librrds-perl libdatetime-event-sunrise-perl libdatetime-event-recurrence-perl libtimedate-perl rrdtool hddtemp libmodule-install-perl libcatalyst-perl libtemplate-perl libdbd-sqlite3-perl libclass-dbi-sqlite-perl libclass-dbi-loader-relationship-perl libclass-dbi-asform-perl libclass-dbi-fromform-perl libcatalyst-plugin-formvalidator-perl libdatetime-format-strptime-perl libclass-dbi-sweet-perl libtemplate-perl libcatalyst-modules-perl
Reading package lists... Done
Building dependency tree... Done
librrds-perl is already the newest version.
libdatetime-event-sunrise-perl is already the newest version.
libdatetime-event-recurrence-perl is already the newest version.
libtimedate-perl is already the newest version.
rrdtool is already the newest version.
hddtemp is already the newest version.
libmodule-install-perl is already the newest version.
libcatalyst-perl is already the newest version.
libtemplate-perl is already the newest version.
libdbd-sqlite3-perl is already the newest version.
libclass-dbi-sqlite-perl is already the newest version.
libclass-dbi-loader-relationship-perl is already the newest version.
libclass-dbi-asform-perl is already the newest version.
libclass-dbi-fromform-perl is already the newest version.
libcatalyst-plugin-formvalidator-perl is already the newest version.
libdatetime-format-strptime-perl is already the newest version.
libclass-dbi-sweet-perl is already the newest version.
libtemplate-perl is already the newest version.
libcatalyst-modules-perl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I've got all the packages allready installed.
The xpl-perl installation was almost ok. I've copyed the complete logging I've had as the 3th post. But when everything
works, I'm going to do the installation again with minimum packages to make a good documentation, and I'm willing to update yours so everyone has a central installation point of info.

Still one thing to figure out after: zenah# perl Makefile.PL
Please run "make catalyst_par" to create the PAR package!
- Catalyst ...missing. (would need 5.64)
Warning: prerequisite Catalyst 5.64 not found. We have unknown version. (I think version 7..something)

otherwise, maybe I can alter the configuration if the versions are compatible.

And I went again a bit further:

Digest::SHA (complains about missing cc, I think compiler)
apt-get install gcc binutils-doc gcc-2.95-doc gcc-4.1-locales manpages-dev autoconf automake1.9 libtool flex bison gdb libc6-dev-amd64 lib64gcc1 lib64ssp0


*** Catalyst installation failed.
*** Module::AutoInstall installation finished.
include /download/zenah/inc/Module/Install.pm
Please install PAR::Packer
make: *** [catalyst_par] Error 2

cpan install PAR::Packer (needed for
problems, solved by adding a link with name libperl.so wich points to libperl.so.version-something in /usr/lib/
/usr/lib# ln libperl.so.5.8 libperl.so

now, for zenah: After perl Makefil.PL and make, it says: make catalyst_par, so I did:

*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.
include inc/Module/Install/Scripts.pm
include inc/Module/Install/AutoInstall.pm
include inc/Module/Install/Include.pm
include inc/Module/AutoInstall.pm
CPAN: File::HomeDir loaded ok (v0.67)
*** Installing dependencies...
*** Installing Catalyst...
CPAN: Storable loaded ok (v2.15)
Going to read /root/.cpan/Metadata
Database was generated on Thu, 24 Jan 2008 02:31:31 GMT
Catalyst is up to date (5.7012).
*** Catalyst installation failed.
*** Module::AutoInstall installation finished.
include /download/zenah/inc/Module/Install.pm
Writing PAR "zenah.par"
make: *** [catalyst_par] Error 2

Now it has to be just a realy small thing to get the catalyst_par going... don't know what I have to do with the par file if it works.
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby Snelvuur » Fri Jan 25, 2008 9:29 am

include inc/Module/Install/Catalyst.pm
*** Module::Install::Catalyst
include inc/Module/Install/Makefile.pm
Please run "make catalyst_par" to create the PAR package!
*** Module::Install::Catalyst finished.

the par seems a normal error, i can just continue.

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Fri Jan 25, 2008 9:37 am

Damn, how lucky could my day start:

cpan
force install Scalar::Util

and I could start up the web interface with: perl -Iblib/lib blib/script/zenah_server.pl

It gives me a warning, so I've got to check this one out also:
[warn] You are running an old script!

Please update by running (this will overwrite existing files):
catalyst.pl -force -scripts ZenAH

or (this will not overwrite existing files):
catalyst.pl -scripts ZenAH

---------

I was wondering how I could see that the backend of zenah got the messages from the xpl-hub, which received it from xpl-rfxcom. and on the "history" / "temp" page I could see:
temp thr128.0e 5 2008-01-25 09:29:13 2008-01-25 09:30:13
This has to be 5 degrees I think, because it was cold this morning ;)

Now up2 the second stage, finding out how to do something with all the input and output.
And ofcouse, sending rf data (klick-on-klick-off) with lan-rfxcom
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Fri Jan 25, 2008 10:38 am

# perl -Iblib/lib blib/script/zenah
closing dbh with active statement handles at /usr/local/share/perl/5.8.8/Class/DBI/Loader/SQLite.pm line 110.

So it still gives me the error message as described on binkeys page, but in the config it uses:
dsn = dbi:SQLite:zenah.db

And checking this zenah.db file in the zenah dir shows me that it is using it. So likely it's an error message, but it still works ok.
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Installation of Zenah

Postby Snelvuur » Fri Jan 25, 2008 11:00 am

I asked the author if he has some space time to look at this thread, although he's pretty busy these days. I think he was also busy with the "sender" part of rfxcom. Maybe he has some in cvs on which you can continue perhaps.

// Erik (binkey.nl)
User avatar
Snelvuur
Forum Moderator
Forum Moderator
 
Posts: 3155
Joined: April 2007
Location: Netherlands

Installation of Zenah

Postby gb1980 » Fri Jan 25, 2008 11:28 am

As this topic is finished "installation of Zenah" I'll stop putting information in this one and start all over again to sort things out so the installation-documentation can be updated.
Thank you snelvuur for all the fast reply's!
gb1980
Member
Member
 
Posts: 52
Joined: December 2007
Location: Netherlands

Next

Return to Linux Forum

Who is online

Users browsing this forum: No registered users and 0 guests